Comments

797 Comments

Tested in F31 Beta RC 1.1

For the record, testing this myself it seems we're still missing something, as I don't get the correct F31 background for a desktop session. I get an upstream KDE background called 'Next' instead. However, this is still technically an improvement on the previous state, as it means we're at least not using the same background as F30 did, which means we're not violating the Basic release criteria any more.

Note to self: this depends on the CommonMark update. Don't push it stable till that one is stable.

For the record, @lruzicka 's problem appears to have been down to the perl client now defaulting to https rather than http.

It's been running on the staging instance since a bit before I submitted the update, and hasn't shown any such problem there. Bit hard to tell what's going on in your instance without more details...

This update breaks OpenQA functionality on my machine. After update, OpenQA starts without problems, but does not accept commands via openqa-client with "ERROR: Connection refused". Nothing is shown in logs. Downgrading to previous version fixes the problem.

test comment, please ignore

Works

BZ#1718622 Red Hat subscription showing during installation process
karma

Works

Works for me.

BZ#1718622 Red Hat subscription showing during installation process

A little bit weird that this package already installed for me:

python3-bodhi-4.0.2-2.fc30.noarch already installed

Yeah, I think we shouldn't be pulling this in on Fedora at all, but that's a separate issue. I'll file a bug on that.

@mattf yeah, that's correct, the %postun of 5.1.0-7 was also broken and of course that can't be helped once it's installed. I just checked and it is fixed in both places in -8.

@adamwill I didn't see the post-install scriptlet error for libvirt-daemon-driver-network-5.1.0-8, but that error showed up when the post-uninstall scriptlet of libvirt-daemon-driver-network-5.1.0-7 ran. I think that scriptlet error is fixed in 5.1.0-8. The error in #1699051 didn't show up in my journal after upgrading to 5.1.0-7. Thanks. I haven't tested libvirtd 5.1.0-8.

BZ#1699051 libvirt installs firewalld zonefile that uses rule priorities, which aren't yet supported by F30 firewalld

Works for me but adds a center item on the passwords page... and an extra step first boot... for something that shouldn't be there but thanks for making it work again.

works now

BZ#1713109 KDE live installs fail with "TypeError: setup() missing 1 required positional argument: 'payload'"
karma

Fixes the original problem and the additional reported issue - I personally didn't observe that in my install but I think had done some install and removal of the packages manually.

BZ#1699051 libvirt installs firewalld zonefile that uses rule priorities, which aren't yet supported by F30 firewalld