Comments

713 Comments

Works for me (incl. empty username and username change). Used client package was gsi-openssh-8.2p1-2 from Fedora Core 33.

Works for me (incl. empty username and username change). Used client package was gsi-openssh-8.1p1-2 from Fedora Core 33.

Works for me (incl. empty username and username change). Used client package was gsi-openssh-7.6p1-bp150.135.1 from SLES 15 used in openSUSE Leap 15.0 (provided by the Grid Community Toolkit packages on 1).

Works for me (incl. empty username and username change). Used client package was gsi-openssh-7.9p1-lp151.146.1 from openSUSE Leap 15.1 (provided by the Grid Community Toolkit packages on 1).

Works for me (incl. empty username and username change). Used client package was gsi-openssh-8.1p1-2 from Fedora Core 31.

BZ#1751407 ROOT needs to be recompiled with gcc9.2
karma

Works, seems to fix the issues with ROOT. Thanks!

BZ#1704691 ROOT gui is not working
BZ#1704691 ROOT gui is not working
BZ#1704691 ROOT gui is not working

works as expected

OK, thanks for the info and sorry for the noise. So, libxxhash is statically linked to xxhsum. Not sure if this should be changed. I thought, xxhsum works similar to md5sum or sha256sum which wait for input when they're called without filename.

The binaries do not link to the shared library, so there is no dependency between the packages.

$ ldd /usr/bin/xxhsum 
    linux-vdso.so.1 (0x00007ffc461f8000)
    libc.so.6 => /lib64/libc.so.6 (0x00007f49c9746000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f49c9956000)

The binaries read from stdin when there is a pipe or redirection:

echo 'xxx' | xxhsum
xxhsum < filename

If stdin is a tty it considers this "Wrong parameters".

When calling xxhsum without parameters, it shows the message "Wrong parameters" together with short usage information. According to this info, xxhsum should read data from stdin if no filename or "-" is provided instead of quitting.

Since the base package doesn't require the current version of xxhash-libs, xxhsum and libxxhash may be out of sync, e.g. xxhsum 0.7.0 uses libxxhash 0.6.5. It's not a big problem but maybe you could consider adding "Requires: %{name}-libs = %{version}-%{release}" to the base package.

BZ#1673802 CVE-2019-7639 gsi-openssh: enabling PermitPAMUserChange allows to login with the correct username and wrong password [fedora-all]

This seems to be working as expected now.

BZ#1673802 CVE-2019-7639 gsi-openssh: enabling PermitPAMUserChange allows to login with the correct username and wrong password [fedora-all]