Comments

560 Comments

Well, the problem seems to be OpenJDK 1.8 compatibility issue. It also affects F32. Works fine with OpenJDK 11 (tested under F32).

Well, got an error when trying to run a C++ binary:

An internal error occurred during: "Creating console for /home/hedayat/projects/blahblah (۱۳۹۹/۱/۲۰،‏ ۱۸:۵۵)". java.nio.ByteBuffer.flip()Ljava/nio/ByteBuffer;

Well no, I was wrong. it is OK now. Don't know what happened. sorry.

Default theme (Light) looks ugly in this update. Looks darker, and also e.g. combo boxes are gray instead of white. Or, briefly, it doesn't look like the one in stable.

but anyway, it is functional.

No regressions noted

Works well, no regressions noted.

Works

I still cannot install eclipse:

Error: 
 Problem: conflicting requests
  - package eclipse-jdt-1:4.14-5.fc31.noarch requires eclipse-platform = 1:4.14-5.fc31, but none of the providers can be installed
  - package eclipse-jdt-1:4.11-3.fc31.noarch requires eclipse-platform = 1:4.11-3.fc31, but none of the providers can be installed
  - package eclipse-platform-1:4.14-5.fc31.x86_64 requires glassfish-el >= 3.0.1, but none of the providers can be installed
  - package eclipse-platform-1:4.11-3.fc31.x86_64 requires glassfish-el >= 3.0.1, but none of the providers can be installed
  - package glassfish-el-3.0.1-0.12.b08.module_f31+6519+12cd0b27.noarch is filtered out by modular filtering
  - package glassfish-el-3.0.1-0.12.b08.module_f31+6793+1c93c38e.noarch is filtered out by modular filtering
  - package glassfish-el-3.0.1-0.11.b08.fc31.noarch is filtered out by modular filtering

This update has been unpushed.

karma

The update break dogtag in freeIPA

https://bugzilla.redhat.com/show_bug.cgi?id=1783709

@adamwill FYI

This update definitely fixes the FTBFS issue and doesn't seem to cause any problems since it landed.

BZ#1735207 felix-bundlerepository: FTBFS in Fedora rawhide/f31

Eclipse CDT indexer doesn't work correctly. Probably because of: https://bugs.eclipse.org/bugs/show_bug.cgi?id=548482

An update to eclipse CDT 9.8.1 seems to fix the problem.

Works for me.

Install fails with: - package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed - package eclipse-platform-1:4.11-4.fc30.x86_64 requires glassfish-el >= 3.0.1, but none of the providers can be installed - package glassfish-el-3.0.1-0.10.b08.fc30.noarch is excluded