Comments

350 Comments

qutebrowser/falkon play vids now with the new qt6-qtwebengine build. Thanks @jgrulich.

Thanks, works flawlessly.

@jgrulich: awesome, thanks very much. Please do let me know if i can help with testing (even if not as part of this update).

@jgrulich: I see that the proprietary codecs have been turned off in qt6-qtwebengine with 6.7.0: is this intentional please? What should users be using instead, is a -freeworld package required in RPM Fusion then?

https://src.fedoraproject.org/rpms/qt6-qtwebengine/c/def205233368da15b55a838b864402ab73a8e40e?branch=rawhide

Yep, works if I downgrade:

$ rpm -qa \*qt6-qtwebengine\*
qt6-qtwebengine-6.6.2-1.fc40.x86_64
qt6-qtwebengine-devtools-6.6.2-1.fc40.x86_64

Neither falkon nor qutebrowser can now play videos on Facebook, X etc. Is there another package one needs to install? (I thought we didn't need a -freeworld etc. any more)

$ rpm -qa \*qt6-qtwebengine\*
qt6-qtwebengine-6.7.0-1.fc40.x86_64
qt6-qtwebengine-devtools-6.7.0-1.fc40.x86_64

@jgrulich: would you know when you plan to submit this one for stable please? (I need to rebuild qt5-qtwebengine-freeworld in RPM Fusion when this hits the updates repos)

Also seeing this:

Problem 1: cannot install the best update candidate for package python3-rpmautospec-0.3.8-1.fc39.noarch                                                                     
  - nothing provides (python3.12dist(rpmautospec-core) < 0.2~~ with python3.12dist(rpmautospec-core) >= 0.1.4) needed by python3-rpmautospec-0.4.2-1.fc39.noarch from updates
-testing                                                                                                                                                                     
 Problem 2: package rpmautospec-0.4.2-1.fc39.noarch from updates-testing requires python3-rpmautospec = 0.4.2-1.fc39, but none of the providers can be installed            
  - cannot install the best update candidate for package rpmautospec-0.3.8-1.fc39.noarch                                                                                    
  - nothing provides (python3.12dist(rpmautospec-core) < 0.2~~ with python3.12dist(rpmautospec-core) >= 0.1.4) needed by python3-rpmautospec-0.4.2-1.fc39.noarch from updates
-testing                                                                                                                                                               

I see the latest version of python-rpmautospec-core is 0.1.3:

FEDORA-2024-c03a9cf3f1

Looks like this doesn't go with the current version of python-boto that's available in F39:

 Problem: package python3-boto3-1.28.21-1.fc39.noarch from @System requires (python3.12dist(s3transfer) < 0.7~~ with python3.12dist(s3transfer) >= 0.6), but none of the providers can be installed
  - cannot install both python3-s3transfer-0.7.0-1.fc39.noarch from updates-testing and python3-s3transfer-0.6.2-1.fc39.noarch from @System
  - cannot install both python3-s3transfer-0.7.0-1.fc39.noarch from updates-testing and python3-s3transfer-0.6.2-1.fc39.noarch from fedora
  - cannot install the best update candidate for package python3-s3transfer-0.6.2-1.fc39.noarch
  - cannot install the best update candidate for package python3-boto3-1.28.21-1.fc39.noarch
BZ#2241155 python-s3transfer-0.7.0 is available

Installs fine

BZ#2220423 F39FailsToInstall: python3-pybv
BZ#2226287 python-pybv: FTBFS in Fedora rawhide/f39

Installs fine now.

BZ#2220505 F39FailsToInstall: python3-sklearn-genetic-opt

Grabbed the build from koji. Works like a charm :)

BZ#2232875 qutebrowser-3.0.0 is available

Filed upstream: https://github.com/qutebrowser/qutebrowser/issues/7927, will file one at our bugzilla too.

I can't seem to launch it at all. I get an immediate crash with qt6, even using a temporary basedir with -T . If I force it to use qt5 bits, it still launches.

rpm -qa *qutebrowser* qt* qt5-qttools-common-5.15.10-3.fc39.noarch qt-settings-39.0-1.fc39.noarch qt5-srpm-macros-5.15.10-2.fc39.noarch qt5-qtsvg-5.15.10-2.fc39.x86_64 qt5-qtx11extras-5.15.10-2.fc39.x86_64 qt5-qtwayland-5.15.10-4.fc39.x86_64 qt5-qtdeclarative-5.15.10-2.fc39.x86_64 qt5-qtwebchannel-5.15.10-2.fc39.x86_64 qt5-qtlocation-5.15.10-3.fc39.x86_64 qt5-qtxmlpatterns-5.15.10-2.fc39.x86_64 qt5-qttools-libs-help-5.15.10-3.fc39.x86_64 qt5-qtsensors-5.15.10-2.fc39.x86_64 qt5-qtwebkit-5.212.0-0.78alpha4.fc39.x86_64 qt5-qttools-libs-designer-5.15.10-3.fc39.x86_64 qt5-qtconnectivity-5.15.10-2.fc39.x86_64 qt5-qtgraphicaleffects-5.15.10-2.fc39.x86_64 qt5-qtquickcontrols2-5.15.10-2.fc39.x86_64 qt5-qtscxml-5.15.10-2.fc39.x86_64 qt5-qtserialport-5.15.10-2.fc39.x86_64 qt5-qtwebsockets-5.15.10-2.fc39.x86_64 qt-common-4.8.7-74.fc39.noarch qt-4.8.7-74.fc39.x86_64 qt-x11-4.8.7-74.fc39.x86_64 qt5-qtmultimedia-5.15.10-2.fc39.x86_64 qt5-qtgamepad-5.15.10-2.fc39.x86_64 qt5-qtscript-5.15.10-2.fc39.x86_64 qt5-rpm-macros-5.15.10-2.fc39.noarch qt5-qtbase-common-5.15.10-9.fc39.noarch qt5-qtbase-5.15.10-9.fc39.x86_64 qt6-qttools-common-6.5.2-1.fc39.noarch qt5-qtbase-gui-5.15.10-9.fc39.x86_64 qt6-qtbase-common-6.5.2-5.fc39.noarch qt6-qtsvg-6.5.2-1.fc39.x86_64 qt6-qtbase-gui-6.5.2-5.fc39.x86_64 qt6-qtbase-6.5.2-5.fc39.x86_64 qt6-qtwayland-6.5.2-3.fc39.x86_64 qt6-qtdeclarative-6.5.2-1.fc39.x86_64 qt6-qtspeech-6.5.2-3.fc39.x86_64 qt6-qtspeech-speechd-6.5.2-3.fc39.x86_64 qt6-qtwebchannel-6.5.2-1.fc39.x86_64 qt6-qtpdf-6.5.2-2.fc39.x86_64 qt6-qtserialport-6.5.2-1.fc39.x86_64 qt6-qtpositioning-6.5.2-1.fc39.x86_64 qt6-qtwebengine-6.5.2-2.fc39.x86_64 qt6-qtwebengine-devtools-6.5.2-2.fc39.x86_64 qt6-qtmultimedia-6.5.2-1.fc39.x86_64 qt6-qtquicktimeline-6.5.2-1.fc39.x86_64 qt6-qtremoteobjects-6.5.2-1.fc39.x86_64 qt6-qtsensors-6.5.2-1.fc39.x86_64 qt6-qttools-libs-designer-6.5.2-1.fc39.x86_64 qt6-qtconnectivity-6.5.2-1.fc39.x86_64 qt6-qtshadertools-6.5.2-1.fc39.x86_64 qt6-qtquick3d-6.5.2-1.fc39.x86_64 qt6-qttools-libs-help-6.5.2-1.fc39.x86_64 qt6-qtwebsockets-6.5.2-1.fc39.x86_64 qutebrowser-3.0.0-2.fc39.noarch qtpass-1.4.0-1.fc39.x86_64 qt5-qtbase-devel-5.15.10-9.fc39.x86_64 qt6-srpm-macros-6.5.2-3.fc39.noarch qt5-qtwebengine-5.15.12-8.fc39.x86_64 qt5-qtwebengine-devtools-5.15.12-8.fc39.x86_64 qt5-qtwebengine-freeworld-5.15.12-5.fc39.x86_64

BZ#2232875 qutebrowser-3.0.0 is available
karma

Seems to work fine here with IRC and wee-slack

BZ#2133353 weechat-4.0.4 is available
BZ#2222649 F39FailsToInstall: weechat
BZ#2226507 weechat: FTBFS in Fedora rawhide/f39

This update is for F38 and was pushed to stable months ago. Please file a new bug for F39.

Fixes the conflict

Seem to be getting a file conflict here:

$ sudo dnf update
Last metadata expiration check: 0:39:27 ago on Thu 20 Apr 2023 17:26:45 BST.
Dependencies resolved.
==============================================================================================================================================================================================
 Package                                           Architecture                           Version                                       Repository                                       Size
==============================================================================================================================================================================================
Upgrading:
 python3-nbclassic                                 noarch                                 0.5.5-2.fc38                                  updates-testing                                 4.4 M

Transaction Summary
==============================================================================================================================================================================================
Upgrade  1 Package

Total download size: 4.4 M
Is this ok [y/N]: y
Downloading Packages:
python3-nbclassic-0.5.5-2.fc38.noarch.rpm                                                                                                                     7.0 MB/s | 4.4 MB     00:00    
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                         3.7 MB/s | 4.4 MB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction test error:
  file /usr/lib/python3.11/site-packages/nbclassic/static/components/font-awesome/css from install of python3-nbclassic-0.5.5-2.fc38.noarch conflicts with file from package python3-nbclassic-0.5.1-1.fc38.noarch

Sorry about that! I'll do that now.

This update has been unpushed.