Comments

315 Comments
BZ#1914246 python-uvicorn fails to build with Python 3.10 due to problem in python-websockets: the *loop* parameter was removed from Lock()
BZ#1966531 python-uvicorn-0.15.0 is available
BZ#1968971 F35FailsToInstall: python3-falcon
BZ#1969166 F35FailsToInstall: python3-uvicorn+standard, python3-uvicorn. The build hangs in %check
BZ#1987895 python-uvicorn: FTBFS in Fedora rawhide/f35
BZ#1988073 python-falcon: FTBFS in Fedora rawhide/f35
BZ#2002542 python-websockets-10.0 is available

python3-{falcon,httptools,uvicorn,websockets} all install fine, but python3-pytest-sanic does not.

Error: 
 Problem: conflicting requests
  - nothing provides (python3.10dist(websockets) < 9 with python3.10dist(websockets) >= 8.1) needed by python3-pytest-sanic-1.7.0-3.fc35.noarch
  - nothing provides python3.10dist(httpx) >= 0.18.1 needed by python3-pytest-sanic-1.8.1-2.fc35.noarch
BZ#1914246 python-uvicorn fails to build with Python 3.10 due to problem in python-websockets: the *loop* parameter was removed from Lock()
BZ#1966531 python-uvicorn-0.15.0 is available
BZ#1968971 F35FailsToInstall: python3-falcon
BZ#1969166 F35FailsToInstall: python3-uvicorn+standard, python3-uvicorn. The build hangs in %check
BZ#1985599 F35FailsToInstall: python3-pytest-sanic
BZ#1987895 python-uvicorn: FTBFS in Fedora rawhide/f35
BZ#1988073 python-falcon: FTBFS in Fedora rawhide/f35
BZ#2002542 python-websockets-10.0 is available

This update has been unpushed.

Error: 
 Problem: package compose-utils-0.1.45-2.el8.noarch requires python3-compose-utils = 0.1.45-2.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides python3-productmd >= 1.33 needed by python3-compose-utils-0.1.45-2.el8.noarch
  - nothing provides python3.6dist(productmd) >= 1.33 needed by python3-compose-utils-0.1.45-2.el8.noarch

This update doesn't install.

# dnf --enablerepo updates-testing update --advisory FEDORA-2021-0c53d8738d
Last metadata expiration check: 0:35:23 ago on Wed 09 Jun 2021 09:50:34 PM CDT.
Dependencies resolved.

 Problem: package podman-3:3.2.0-4.fc33.x86_64 requires crun < 0.20-1, but none of the providers can be installed
  - cannot install both crun-0.20.1-1.fc33.x86_64 and crun-0.19.1-3.fc33.x86_64
  - cannot install both crun-0.20.1-1.fc33.x86_64 and crun-0.15-5.fc33.x86_64
  - cannot install the best update candidate for package podman-3:3.1.2-2.fc33.x86_64
  - cannot install the best update candidate for package crun-0.19.1-3.fc33.x86_64
==============================================================================================
 Package                         Arch       Version                 Repository           Size
==============================================================================================
Upgrading:
 containernetworking-plugins     x86_64     1.0.0-0.2.rc1.fc33      updates-testing     9.9 M
 containers-common               noarch     4:1-17.fc33             updates-testing      59 k
 crun                            x86_64     0.20.1-1.fc33           updates-testing     171 k
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 crun                            x86_64     0.15-5.fc33             fedora              156 k
Skipping packages with broken dependencies:
 podman                          x86_64     3:3.2.0-4.fc33          updates-testing      12 M

Transaction Summary
==============================================================================================
Upgrade  3 Packages
Skip     2 Packages

Total download size: 10 M
Is this ok [y/N]: