Comments

496 Comments

For the record, the contents of the package is nearly the same as before. It only differs in:

  • pycs content
  • timestamps
  • 2 license files marked as much by packaging automation
  • release number
$ rpmdiff -iT ./python3-pyglet-1.5.16-{3,4}.fc35.noarch.rpm | grep -v '\.pyc$'
removed     PROVIDES python-pyglet = 1.5.16-3.fc35
removed     PROVIDES python3-pyglet = 1.5.16-3.fc35
removed     PROVIDES python3.10-pyglet = 1.5.16-3.fc35
added       PROVIDES python-pyglet = 1.5.16-4.fc35
added       PROVIDES python3-pyglet = 1.5.16-4.fc35
added       PROVIDES python3.10-pyglet = 1.5.16-4.fc35
removed     OBSOLETES python-pyglet < 1.5.16-3.fc35
added       OBSOLETES python-pyglet < 1.5.16-4.fc35
.........F. /usr/lib/python3.10/site-packages/pyglet-1.5.16.dist-info/LICENSE
.........F. /usr/lib/python3.10/site-packages/pyglet-1.5.16.dist-info/NOTICE

Hence, I am quite confident that functionality remains intact.

I've opened a releng ticket 2 years ago: https://pagure.io/releng/issue/8948

BZ#2008912 glib2-devel installation error: file /usr/share/glib-2.0/codegen/__pycache__/codegen_docbook.cpython-310.pyc conflicts between attempted installs of glib2-devel-2.70.0-3.fc35.i686 and glib2-devel-2.70.0-3.fc35.x86_64

This requires the python3.9dist(coverage[toml]) provide and needs the python-coverage package to be updated to add the toml extra subpackage.

This requires the python3.10dist(coverage[toml]) provide and needs the python-coverage package to be updated to add the toml extra subpackage.

BZ#1865212 pew: FTBFS in Fedora rawhide/f33
BZ#1968843 F35FailsToInstall: module-build-service; fails to build: Uses broken, deprecated and orphaned python-flask-script, not compatible with Flask 2
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides python3-flask-script needed by module-build-service-3.6.1-5.fc36.noarch
BZ#1968843 F35FailsToInstall: module-build-service; fails to build: Uses broken, deprecated and orphaned python-flask-script, not compatible with Flask 2
BZ#2008899 python-kerberos: SystemError: PY_SSIZE_T_CLEAN macro must be defined for '#' formats
BZ#2004484 The openssl1.1-devel package is not usable on Fedora 33, 34 and 35

And after consideration, I've removed python-pytest-sanic-1.8.1-2.fc35 -- including it here does not add any benefit -- the python-pytest-sanic-1.7.0-3.fc35 build from stable already fails to install for other reasons. The other update in testing, python-pytest-sanic-1.8.1-1.fc35, fails to install for other reasons and python-pytest-sanic-1.8.1-1.fc35 only fixes the dependency problem introduced here. If the maintainer fixes the other problems, they will build open our fixes here.

Error: 
 Problem: conflicting requests
  - nothing provides python3.10dist(httpx) >= 0.18.1 needed by python3-pytest-sanic-1.8.1-1.fc35.noarch
BZ#1962470 python-pytest-sanic-1.8.1 is available
BZ#1985599 F35FailsToInstall: python3-pytest-sanic

I've removed BZ#1985599 from this update as it clearly does not fix it.

If it makes it easier to land the other changes, we could remove pytest-sanic from this FE update. We could even unpush the python-pytest-sanic-1.8.1 update altogether and revert back to 1.7.0 with the fix included here, but that would require some maintainer cooperation :/

nothing provides (python3.10dist(websockets) < 9 with python3.10dist(websockets) >= 8.1) needed by python3-pytest-sanic-1.7.0-3.fc35.noarch

This has been fixed by this upgrade, python-pytest-sanic-1.8.1-2.fc35.

nothing provides python3.10dist(httpx) >= 0.18.1 needed by python3-pytest-sanic-1.8.1-2.fc35.noarch

This was already broken before this upgrade and not introduced here. It would certainly be nice to fix that as well, but since the maintainer ignores my FailsToInstall bugzillas and since updating httpx might break something else, I decided not to dive into this.

This update has been unpushed.