Comments

328 Comments

@besser82 Could you please retest? I had to make more changes.

ipython now provides ipython2 / ipython3. notebook now recommends terminado

Note that this istestable from Mock, if you are not running Fedora 26 yet. All you need to do is to create a mock config with updates-testing.

cp /etc/mock/fedora-26-x86_64.cfg /etc/mock/fedora-26-x86_64-testing.cfg

edit /etc/mock/fedora-26-x86_64-testing.cfg (find [updates-testing], change enabled to 1)

run:

mock -r fedora-26-x86_64-testing --init
mock -r fedora-26-x86_64-testing --install \
        notebook ipython2 python2-ipykernel
mock -r fedora-26-x86_64-testing --shell
  • Test ipython3.
  • Test ipython2.
  • Test jupyter-notebook
    • Test both kernels (2 and 3) in notebook

I see "Python detected LC_CTYPE=C: LC_ALL & LANG coerced to C.UTF-8 (set another locale or PYTHONCOERCECLOCALE=0 to disable this locale coercion behaviour)." as described. Click works. Python3 works. Dnf works.

BZ#1404918 Proposal: force C.UTF-8 when Python 3 is run under the C locale

This update has been unpushed.

Trying to install firmware from http://download.lulzbot.com/Mini/1.04/software/firmware/Mini-Single-or-Flexystruder-LBHexagon-v1.1.0.11.hex via Install custom firmware segfaults before the upload starts on this cura-lulzbot and the one in stable as well.

After uploading the new firmware, the printer communicates with Cura and sends acks but does not move (heating works).

When uploading the firmware (the crash is after the upload is successful):

load preferences from /home/churchyard/.cura-lulzbot/21.03/preferences.ini
Listening for engine communications on 49674
Flashing 84260 bytes
Verifying 84260 bytes
Segmentation fault (core dumped)

Oh, sorry, I didn't have the chance. Maybe next Monday.

Bad provides, see #1411169

Starts and slices fine. Will try the new Mini firmaware and homing on Monday.

Resolved the TLS Certificate transparency error.

BZ#1403936 Chromium 55 is available
BZ#1403611 chromium shows error on ssl-sites secured by symantec certificates

Fixes #1397699

karma

I've tested it with tox and it worked.

BZ#1332978 update to a newer release or merge with pypy package

Requires /usr/bin/python

This update has been unpushed.

Requires /usr/bin/python