Comments

273 Comments

You cannot drop python2-more-itertools from stable releases. Also I consider update from 4.1.0 to 7.0.0 a bit dangerous as well.

What does this do (you can N it, when it asks Is this ok [y/N])?

$ sudo dnf --releasever=30 --setopt=module_platform_id=platform:f30 --enablerepo=updates-testing distro-sync

"Problem: both package blockdiag-1.5.4-4.fc30.noarch and fedora-obsolete-packages-30-40.noarch obsolete python2-blockdiag < 1.5.4-2" seems like this will get fixed when this is moved form updates testing. I hope.

I'd like to see the conflict. I don't understand why it is not par of the error message.

This update has been unpushed.

I get this error:

Transaction check error:
  file /usr/bin/distro from install of python36-distro-1.2.0-2.el7.noarch conflicts with file from package python2-distro-1.2.0-1.el7.noarch
karma

No regressions

@labbott, it seems that #1701226 was added here by accident, however I cannot edit the update without specifying the severity.

No regressions noted.

Basic screenshotting works.

Updating from selinux-policy-targeted-3.14.2-49.fc29 to selinux-policy-targeted-3.14.2-51.fc29 - the scriptlet turned my CPU into a grill, my X session and Xfce desktop crashed and dnf failed mid transaction.

Could you please check (after upgrade):

$ rpm -q --requires singularity-runtime | grep python3
$ rpm -qf /usr/bin/python3
$ rpm -q --whatprovides /usr/bin/python3

And if you have singularity installed and do the update, python36 is not installed?

Let me just say that if other RPM packages actually depend on /usr/bin/python3, you'll get /usr/bin/python3. However if non RPM software you use depends on it, you are now in trouble. So what you expect is a reasonable thing to ask.

Thanks. I'll move this to the mailing list (a better place to discuss this).

What does yum --enablerepo=epel-testing update actually do then?