Comments

772 Comments

I tagged all builds from this update except qt6-qttools into a new side tag and created a new update: FEDORA-2021-db1ce7a5aa

So far, the new one does not seem to be stuck or blocked. Move your karma points there if you want it to finally be pushed to stable.

koji claims that the side tag this update was created from does no longer exist, so I can't edit the update to remove qt6-qttools. I'll try to create a new update from the builds in this update, since this one is apparently completely borked now.

Cannot submit qt6-qttools ('0', '6.1.0', '3.fc34') to testing since it is older than ('0', '6.1.1', '1.fc34')

qt6-qttools still needs to be rebuilt in the side tag for this update, otherwise it can't even be pushed to testing.

Now there's an issue with qt6-qttools:

Cannot submit qt6-qttools ('0', '6.1.0', '3.fc34') to testing since it is older than ('0', '6.1.1', '1.fc34')

At this point, I think it would be easier to create a new update ...

Still good :shrug:

Test Case rust compile

Looks like this can't be pushed to stable because of a versioning snafu in lldb ... new version 12.0.0-1.fc34 sorts lower than old version 12.0.0-1.rc1.fc34, so probably lldb needs a Release bump to -2 and another rebuild?

Works fine. Default and performance regression tests also pass on all my systems:

  • Ryzen 5800X on ASUS ROG X570-E with NVidia GTX 1070 running negativo17 drivers
  • dell XPS 13 9370 (Intel Core i7 8550U / UHD Graphics 620)

Still good.

Test Case rust compile
karma

Works fine. Default and performance regression tests also pass on all my systems:

  • Ryzen 5800X on ASUS ROG X570-E with NVidia GTX 1070 running negativo17 drivers
  • dell XPS 13 9370 (Intel Core i7 8550U / UHD Graphics 620)

No problems encountered. Also fixes Rust codegen issues on aarch64 when compiling doctests.

Test Case rust compile

Thanks! This unblocks my work packaging async-std for f34.

Works fine. Default and performance regression tests also pass on all my systems:

  • Ryzen 5800X on ASUS ROG X570-E with NVidia GTX 1070 running negativo17 drivers
  • dell XPS 13 9370 (Intel Core i7 8550U / UHD Graphics 620)

Works fine without problems for over a week.

This update should have been obsoleted by: FEDORA-2021-6b01add75e

But since it wasn't, I'm unpushing manually.

After installing this update, my XPS 13 won't boot unless I disable secure boot. Looks like it's the same issue @adamwill has.

User Icon decathorpe commented & provided feedback on shim-15.4-1 a year ago
karma

I'm getting this error with Secure Boot enabled on a Dell XPS 13 9370:

Bootloader has not verified loaded image.
System is compromised. halting

While sounding scary, it looks like this is a bug, and fixed by @adamwill 's pull request?

Still, this update makes my system not boot unless I disable secure boot, which kinda defeats the purpose of a security update.

This update has been unpushed.

Well, since this update is obviously broken, I'll unpush it, and it can be fixed later (if at all - SONAME bumps in stable releases are strongly discouraged, after all). Keeping the broken packages around in the updates-testing repos is not really nice.

This stuck update breaks upgrade path (f34 has 1.40, f33 has 1.41).