Comments

772 Comments
karma

LGTM

python3-molecule from this update is not installable:

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides pre-commit needed by python3-molecule-3.0.2-6.fc30.noarch

Also, is this built from the master branch? Because the f30 branch doesn't have these changes ...

karma

Fixes the LoadError issue with did_you_mean.

BZ#1817178 "bundle install" fails to install nio4r gem by "did_you_mean (LoadError)".
karma

Works great, no issues encountered.

Works fine.

BZ#1810696 youtube-dl-2020.03.24 is available
karma

Works fine so far. Both the default and the performance test suites pass on my systems:

  • AMD Ryzen 1700X + NVidia GTX 1070 w/ negativo17 drivers
  • dell XPS 13 9370 (2018)

Supplements still have to be replaced by Recommends.

dpdk-examples-2:19.11.1-1.fc32 is not installable:

$ mock -r fedora-32-x86_64 --enablerepo updates-testing install dpdk-examples
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides /usr/bin/python33 needed by dpdk-examples-2:19.11.1-1.fc32.x86_64

This is probably caused by a faulty #!/usr/bin/python33 shebang in an example script.

python2-rospkg-1.2.4-1.fc31 is not installable:

$ mock -r fedora-31-x86_64 --enablerepo updates-testing install python2-rospkg
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides python2.7dist(distro) needed by python2-rospkg-1.2.4-1.fc31.noarch

python3-minikerberos-0.2.1-1.fc31 is not installable:

$ mock -r fedora-31-x86_64 --enablerepo updates-testing install python3-minikerberos
Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides python3.7dist(asn1crypto) >= 1.3 needed by python3-minikerberos-0.2.1-1.fc31.noarch

python2-rospkg1-2.4-1.fc30 from this update is not installable (broken dependency on python2-distro)

Looks good, works both on GNOME and on Pantheon. Should this update be included in the fedora 32 GA or is it fine as a zero-day update?

Follow-up: /usr/bin/ld.gold was moved to a separate binutils-gold package on fedora 31+, but is still shipped with binutils on fedora 30. So the dependency should be "Requires: binutils" (if that's even necessary) instead of "Requires: binutils-gold" on fedora 30.

swift-lang 5.2.1 is not installable because of the new explicitly specified dependency on binutils-gold, which doesn't exist.

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides binutils-gold needed by swift-lang-5.2.1-1.fc30.x86_64
karma

Seems to work fine (tested: build, mockbuild, switch-branch, clone).

Sorry about the last comment, I was reminded that this is actually the current (and expected) behaviour.

karma

Uh ... I am still getting incomplete results when querying with virtual provides:

$ sudo dnf repoquery --whatrequires python3-poetry
poetry-0:1.0.5-1.fc32.noarch
python3-chaospy-0:3.0.17-1.fc32.noarch

$ sudo dnf repoquery --whatrequires "python3dist(poetry)"
python3-chaospy-0:3.0.17-1.fc32.noarch

So the fix looks incomplete ...

BZ#1812596 repoquery suddenly missing results in --whatrequires on Fedora 32+ (seem to be related to virtual provides)

This update is not installable:

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides python3.8dist(typing) >= 3.6.1 needed by python3-pyvirtualize-0.10-1.20191018gitdc2d971.fc32.noarch

This update is not installable:

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides python3.7dist(typing) >= 3.6.1 needed by python3-pyvirtualize-0.10-1.20191018gitdc2d971.fc31.noarch