Comments

659 Comments

swift-lang 5.2.1 is not installable because of the new explicitly specified dependency on binutils-gold, which doesn't exist.

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides binutils-gold needed by swift-lang-5.2.1-1.fc30.x86_64
karma

Seems to work fine (tested: build, mockbuild, switch-branch, clone).

Sorry about the last comment, I was reminded that this is actually the current (and expected) behaviour.

karma

Uh ... I am still getting incomplete results when querying with virtual provides:

$ sudo dnf repoquery --whatrequires python3-poetry
poetry-0:1.0.5-1.fc32.noarch
python3-chaospy-0:3.0.17-1.fc32.noarch

$ sudo dnf repoquery --whatrequires "python3dist(poetry)"
python3-chaospy-0:3.0.17-1.fc32.noarch

So the fix looks incomplete ...

BZ#1812596 repoquery suddenly missing results in --whatrequires on Fedora 32+ (seem to be related to virtual provides)

This update is not installable:

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides python3.8dist(typing) >= 3.6.1 needed by python3-pyvirtualize-0.10-1.20191018gitdc2d971.fc32.noarch

This update is not installable:

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides python3.7dist(typing) >= 3.6.1 needed by python3-pyvirtualize-0.10-1.20191018gitdc2d971.fc31.noarch

This update is not installable:

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides python3.7dist(typing) >= 3.6.1 needed by python3-pyvirtualize-0.10-1.20191018gitdc2d971.fc30.noarch

Can you submit this update for fedora 32 as well? I see it was built in koji, but no bodhi update for it was created, and so when upgrading to fedora 32, this package is downgraded to the older version.

Can you PLEASE build gcc and annobin together in a side tag in the future?

Because even though the gcc buildroot override is already disabled again, more than 500 packages failed to build in koschei within that window, which is a huge number of false positive results for maintainers to deal with. This doesn't even account for all the real koji builds that failed while the override was active.

Works great, submitting karma with it right now.

BZ#1818480 rust-fedora-update-feedback-0.5.1 is available

Package is not installable:

Error: 
 Problem: conflicting requests
  - nothing provides (python3.8dist(jsonpath-rw) < 2 with python3.8dist(jsonpath-rw) >= 1.4) needed by home-assistant-cli-0.8.0-2.fc32.noarch

This package is not installable:

Error: 
 Problem: conflicting requests
  - nothing provides python3.7dist(jsonpath-rw) >= 1.4 needed by home-assistant-cli-0.8.0-2.fc31.noarch

If this comment shows up in bodhi, then positive karma was warranted ;)

Works fine so far. Also passes default and performance regression tests on:

  • AMD Ryzen 1700X + NVidia GTX 1070 w/ negativo17 drivers
  • dell XPS 13 9370 (2018)
karma

Seems to work fine during fedpkg usage.

python3-sphinx-press-theme is not installable on fedora 30:

Error: 
 Problem: conflicting requests
  - nothing provides python3.7dist(sphinx) >= 2.0.0 needed by python3-sphinx-press-theme-0.5.1-4.fc30.noarch

python3-nikola is not installable on fedora 30:

Error: 
 Problem: conflicting requests
  - nothing provides python3.7dist(markdown) >= 3.0.0 needed by python3-nikola-8.0.4-9.fc30.noarch

Can confirm this fixes the segfaults which were present in the previous update. Thanks!

BZ#1813550 java segmentation faults in GCC10-built java-1.8.0-openjdk

You might want to delete the custom update name (where you - probably accidentally - entered your FAS username). If you leave that field empty, it defaults to the builds contained in the update.