Comments

20 Comments

Needed for mock 1.3.3 on CentOS 7

BZ#1398249 Latest release of python-distro is 1.0.1
karma

I get the following when performing a yum upgrade on CentOS 7:

[root@hfsvm ~]# yum upgrade mock
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.lax.hugeserver.com
 * epel: mirror.n5tech.com
 * extras: mirror.san.fastserv.com
 * ius: dfw.mirror.rackspace.com
 * updates: mirror.hostduplex.com
Resolving Dependencies
--> Running transaction check
---> Package mock.noarch 0:1.2.21-1.el7 will be updated
---> Package mock.noarch 0:1.3.3-1.el7 will be an update
--> Processing Dependency: python2-distro for package: mock-1.3.3-1.el7.noarch
--> Finished Dependency Resolution
    Error: Package: mock-1.3.3-1.el7.noarch (epel)
       Requires: python2-distro
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Is there a package I need that defines the %py2_build and %py2_install macros?

I get:

+ %py2_build
/var/tmp/rpm-tmp.ggcNJ9: line 29: fg: no job control

rpm --showrc doesn't show any %py2 macros

It almost starts working (well, different traceback...)

pkg_resources.DistributionNotFound: Jinja2

After I installed "python-jinja2" it appears to work fine. Cool utility!

Interested in using this package, but it's not clear how to use it. Invoking "pyp2rpm" with "-h" or "--help" gives a traceback:

Traceback (most recent call last):
  File "/usr/bin/pyp2rpm", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 3007, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 626, in resolve
    raise DistributionNotFound(req)
 pkg_resources.DistributionNotFound: click

I get the same traceback if I invoke with a package name as the argument.

There's no manpage so I'm not sure how to invoke it.

BZ#1312927 Release for EPEL7
User Icon gbailey commented & provided feedback on cgit-0.12-1.el7 4 years ago

Works for me!

BZ#1298912 cgit-0.12 is available
karma

Installed MATE 1.12 desktop; did not observe any issues

This update has been unpushed.

This update has been unpushed.

karma

Works for me!

karma

This build works for me, but doesn't appear to address #1047363. Can we push this package out and unlink #1047363 from it?

karma

There's a change in the defaults when upgrading from fail2ban-0.8.11-2.el6.noarch to fail2ban-0.8.13-1.el6.noarch. 0.8.11 has "ssh-iptables" enabled, while 0.8.13 does not. As a result, users who were relying on ssh filtering will find after the upgrade that "ssh-iptables" is disabled. I'd prefer to see "ssh-iptables" enabled by default (as in the current version); at the very least this kind of config change should be documented in Changelog; release notes, etc.

User Icon gbailey commented & provided feedback on yapet-1.0-1.el6 6 years ago
karma

Have not run into any issues with basic functional testing

karma

Dependency on yum_utils >= 1.1.31 causes problems on EL6: # yum --enablerepo=epel-testing upgrade mock Loaded plugins: auto-update-debuginfo, fastestmirror, refresh-packagekit, security Loading mirror speeds from cached hostfile * base: mirror.steadfast.net * epel: mirror.pnl.gov * epel-debuginfo: mirror.pnl.gov * epel-testing: mirror.pnl.gov * epel-testing-debuginfo: mirror.pnl.gov * extras: mirror.steadfast.net * updates: mirror.steadfast.net Setting up Upgrade Process Resolving Dependencies --> Running transaction check ---> Package mock.noarch 0:1.1.32-1.el6 will be updated ---> Package mock.noarch 0:1.1.37-1.el6 will be an update --> Processing Dependency: yum-utils >= 1.1.31 for package: mock-1.1.37-1.el6.noarch --> Finished Dependency Resolution Error: Package: mock-1.1.37-1.el6.noarch (epel-testing) Requires: yum-utils >= 1.1.31 Installed: yum-utils-1.1.30-17.el6_5.noarch (@updates) yum-utils = 1.1.30-17.el6_5 Available: yum-utils-1.1.30-14.el6.noarch (base) yum-utils = 1.1.30-14.el6 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

karma

Works fine for me.

karma

Works fine.

New install and upgrade both work perfectly.