Comments

1827 Comments

Seems like maybe the gqrx package might be the culprit. After removing all the gnuradio related packages from my system and installing the ones from this update one by one via command line, gqrx-2.14.4-3.fc34.x86_64.rpm wanted to downgrade gnuradio and volk to the previous versions

$sudo dnf install ./gqrx-2.14.4-3.fc34.x86_64.rpm
Last metadata expiration check: 3:26:10 ago on Wed 16 Jun 2021 03:51:15 PM EDT.
Dependencies resolved.
==========================================================================================================================================================
Package                             Architecture             Version                                             Repository                         Size
==========================================================================================================================================================
Installing:
gqrx                                x86_64                   2.14.4-3.fc34                                       @commandline                      657 k
Installing dependencies:
airspyone_host                      x86_64                   1.0.9-11.20180615gitbfb66708.fc34                   fedora                             67 k
gr-iqbal                            x86_64                   0.38.2-1.20210210gitfbee239a.fc34                   fedora                            108 k
gr-osmosdr                          x86_64                   0.2.3-6.20210217gita100eb02.fc34                    updates-testing                   343 k
hackrf                              x86_64                   2018.01.1-9.fc34                                    fedora                             61 k
libosmo-dsp                         x86_64                   0.3-15.fc34                                         fedora                             25 k
Downgrading:
gnuradio                            x86_64                   3.9.0.0-5.fc34                                      fedora                            2.9 M
gnuradio-devel                      x86_64                   3.9.0.0-5.fc34                                      fedora                            370 k
gnuradio-doc                        x86_64                   3.9.0.0-5.fc34                                      fedora                             10 M
gnuradio-examples                   x86_64                   3.9.0.0-5.fc34                                      fedora                            458 k
python3-gnuradio                    x86_64                   3.9.0.0-5.fc34                                      fedora                            2.9 M
volk                                x86_64                   2.4.1-3.fc34                                        fedora                            494 k
volk-devel                          x86_64                   2.4.1-3.fc34                                        fedora                            149 k
volk-doc                            noarch                   2.4.1-3.fc34                                        fedora                            916 k

Transaction Summary
==========================================================================================================================================================
Install    6 Packages
Downgrade  8 Packages

Got these errors during the upgrade

Problem 1: package gqrx-2.14.4-3.fc34.x86_64 requires libgnuradio-analog.so.3.9.0()(64bit), but none of the providers can be installed
- package gqrx-2.14.4-3.fc34.x86_64 requires libgnuradio-blocks.so.3.9.0()(64bit), but none of the providers can be installed
- package gqrx-2.14.4-3.fc34.x86_64 requires libgnuradio-digital.so.3.9.0()(64bit), but none of the providers can be installed
- package gqrx-2.14.4-3.fc34.x86_64 requires libgnuradio-fft.so.3.9.0()(64bit), but none of the providers can be installed
- package gqrx-2.14.4-3.fc34.x86_64 requires libgnuradio-filter.so.3.9.0()(64bit), but none of the providers can be installed
- package gqrx-2.14.4-3.fc34.x86_64 requires libgnuradio-pmt.so.3.9.0()(64bit), but none of the providers can be installed
- package gqrx-2.14.4-3.fc34.x86_64 requires libgnuradio-runtime.so.3.9.0()(64bit), but none of the providers can be installed
- cannot install both gnuradio-3.9.2.0-2.fc34.x86_64 and gnuradio-3.9.0.0-5.fc34.x86_64
- cannot install the best update candidate for package gqrx-2.14.4-3.fc34.x86_64
- cannot install the best update candidate for package gnuradio-3.9.0.0-5.fc34.x86_64
Problem 2: package gr-osmosdr-0.2.3-6.20210217gita100eb02.fc34.x86_64 requires libgnuradio-blocks.so.3.9.0()(64bit), but none of the providers can be installed
- package gr-osmosdr-0.2.3-6.20210217gita100eb02.fc34.x86_64 requires libgnuradio-pmt.so.3.9.0()(64bit), but none of the providers can be installed
- package gr-osmosdr-0.2.3-6.20210217gita100eb02.fc34.x86_64 requires libgnuradio-runtime.so.3.9.0()(64bit), but none of the providers can be installed
- package gr-osmosdr-0.2.3-6.20210217gita100eb02.fc34.x86_64 requires libgnuradio-uhd.so.3.9.0()(64bit), but none of the providers can be installed
- cannot install both gnuradio-3.9.2.0-2.fc34.x86_64 and gnuradio-3.9.0.0-5.fc34.x86_64
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires gnuradio(x86-64) = 3.9.2.0-2.fc34, but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-pmt.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-runtime.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-audio.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-blocks.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-analog.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-qtgui.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-uhd.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-channels.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-digital.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-fec.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-fft.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-filter.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-network.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-soapy.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-trellis.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-video-sdl.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-vocoder.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-wavelet.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-devel-3.9.2.0-2.fc34.x86_64 requires libgnuradio-zeromq.so.3.9.2()(64bit), but none of the providers can be installed
- cannot install the best update candidate for package gr-osmosdr-0.2.3-6.20210217gita100eb02.fc34.x86_64
- cannot install the best update candidate for package gnuradio-devel-3.9.0.0-5.fc34.x86_64
Problem 3: problem with installed package gqrx-2.14.4-3.fc34.x86_64
- package gqrx-2.14.4-3.fc34.x86_64 requires libvolk.so.2.4()(64bit), but none of the providers can be installed
- cannot install both volk-2.5.0-1.fc34.x86_64 and volk-2.4.1-3.fc34.x86_64
- cannot install the best update candidate for package volk-2.4.1-3.fc34.x86_64
Problem 4: problem with installed package gr-osmosdr-0.2.3-6.20210217gita100eb02.fc34.x86_64
- package gr-osmosdr-0.2.3-6.20210217gita100eb02.fc34.x86_64 requires libgnuradio-blocks.so.3.9.0()(64bit), but none of the providers can be installed
- package gr-osmosdr-0.2.3-6.20210217gita100eb02.fc34.x86_64 requires libgnuradio-pmt.so.3.9.0()(64bit), but none of the providers can be installed
- package gr-osmosdr-0.2.3-6.20210217gita100eb02.fc34.x86_64 requires libgnuradio-runtime.so.3.9.0()(64bit), but none of the providers can be installed
- package gr-osmosdr-0.2.3-6.20210217gita100eb02.fc34.x86_64 requires libgnuradio-uhd.so.3.9.0()(64bit), but none of the providers can be installed
- cannot install both gnuradio-3.9.2.0-2.fc34.x86_64 and gnuradio-3.9.0.0-5.fc34.x86_64
- package gnuradio-examples-3.9.2.0-2.fc34.x86_64 requires libgnuradio-pmt.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-examples-3.9.2.0-2.fc34.x86_64 requires libgnuradio-runtime.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-examples-3.9.2.0-2.fc34.x86_64 requires libgnuradio-audio.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-examples-3.9.2.0-2.fc34.x86_64 requires libgnuradio-blocks.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-examples-3.9.2.0-2.fc34.x86_64 requires libgnuradio-analog.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-examples-3.9.2.0-2.fc34.x86_64 requires libgnuradio-qtgui.so.3.9.2()(64bit), but none of the providers can be installed
- package gnuradio-examples-3.9.2.0-2.fc34.x86_64 requires libgnuradio-uhd.so.3.9.2()(64bit), but none of the providers can be installed
- cannot install the best update candidate for package gnuradio-examples-3.9.0.0-5.fc34.x86_64
BZ#1966406 rstudio-1.4.1717 is available

Those of you wanting to make the toolbars go away, right click on the menu bar and uncheck "Main Toolbar" and "Session Toolbar"