Comments

67 Comments

The unit-test-devel rpm is not for installing atm. It is for a CI that is to be implemented. To test the code we need environment that is hard or impossible to create inside the Koji builder.

import ruamel.yaml throws a traceback with python2-typing < 3.5.2.2.

With python2-typing-3.5.2.2-2 installed I was able to import ruamel.yaml and was able to run examples from https://yaml.readthedocs.io/en/latest/example.html successfully.

Still, giving negative karma to fix the minimal version requirementes for python2-typing. The same comment is already provided in the review request bz.

BZ#1386563 Review Request: python-ruamel-yaml - YAML 1.2 loader/dumper package for Python

Ok, the python2-typing is the culprit. The python-ruamel-yaml should (build)require at least 3.5.2.2-2. So keeping the negative karma here. At the same time python2-typing-3.5.2.2-2 is not yet built in f24. So either it needs updating or this update needs to be canceled.

With python2-typing-3.5.2.2-2 installed I was able to import ruamel.yaml and was able to run examples from https://yaml.readthedocs.io/en/latest/example.html successfully.

Tested with as part of testing ruamel.yaml.

import ruamel.yaml throws a traceback.

Installing the ruamel.yaml via pip and importing it works.

Please, do not push this update to stable until I resolve RHEL7 go packages migration to epel7. Keeping the request open so the 14 days testing time is reached asap.

Please, do not push this update to stable until I resolve RHEL7 go packages migration to epel7. Keeping the request open so the 14 days testing time is reached asap.

Please, do not push this update to stable until I resolve RHEL7 go packages migration to epel7. Keeping the request open so the 14 days testing time is reached asap.

Please, do not push this update to stable until I resolve RHEL7 go packages migration to epel7. Keeping the request open so the 14 days testing time is reached asap.

Please, do not push this update to stable until I resolve RHEL7 go packages migration to epel7. Keeping the request open so the 14 days testing time is reached asap.

BZ#1390074 Update to upstream 1.4.5