Traceback (most recent call last): File "/usr/bin/dnf", line 57, in <module> from dnf.cli import main File "/usr/lib/python3.6/site-packages/dnf/__init__.py", line 31, in <module> import dnf.base File "/usr/lib/python3.6/site-packages/dnf/base.py", line 30, in <module> from dnf.module.metadata_loader import ModuleMetadataLoader File "/usr/lib/python3.6/site-packages/dnf/module/metadata_loader.py", line 25, in <module> gi.require_version('Modulemd', '1.0') File "/usr/lib64/python3.6/site-packages/gi/__init__.py", line 134, in require_version (namespace, version)) ValueError: Namespace Modulemd not available for version 1.0
Sure, but I think calling this a "weird error" is acceptable as you just pointed out: we're doing a bad thing, and the error we see isn't that we're doing a bad thing, its that something else, later, way down the line, is broken.
Are you sure that you are not doing a bad thing? OpenQA do the same as normal user would do. Just call
dnf update and the result is combination of packages which cause failures to install freeIPA.
And it is obviously caused by this bodhi update because it pass without updates-testing.
Sure; error reporting could be better. But assumption about
$CURRENT_VERSION+1 is difficult. You can obsolete some packages; replace ... So it is would be a challenge to guess which set of packages should be installed.
I would appreciate if you could either un-push this update from updates-testing or add freeipa-4.7.2 to this update. I am not sure whether you have permissions for that.
Error: Problem: cannot install the best update candidate for package mock-core-configs-29.2-1.fc27.noarch - nothing provides distribution-gpg-keys >= 1.25 needed by mock-core-configs-29.3-1.fc27.noarch
I am lazy to file a BZ :-)
[root@df93b608790c /]# dnf install -y -e0 -d0 https://kojipkgs.fedoraproject.org//packages/libmodulemd/1.1.0/1.fc28/x86_64/libmodulemd-1.1.0-1.fc28.x86_64.rpm libmodulemd-1.1.0-1.fc28.x86_64.rpm 69 kB/s | 92 kB 00:01 [root@df93b608790c /]# rpm -q libmodulemd dnf python3-module libmodulemd-1.1.0-1.fc28.x86_64 dnf-2.7.5-8.fc28.noarch package python3-module is not installed [root@df93b608790c /]# dnf update -y --best Last metadata expiration check: 0:07:38 ago on Thu Mar 15 13:12:38 2018. Error: Problem: cannot install both libmodulemd-1.0.4-2.fc28.x86_64 and libmodulemd-1.1.0-1.fc28.x86_64 - cannot install the best update candidate for package python3-modulemd-1.3.3-1.fc28.noarch - problem with installed package libmodulemd-1.1.0-1.fc28.x86_64 (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages) [root@df93b608790c /]# dnf update -y --best --allowerasing Last metadata expiration check: 0:07:49 ago on Thu Mar 15 13:12:38 2018. Error: Problem: The operation would result in removing the following protected packages: dnf
The issue is still not resolved
it breaks upgrade on f28
[root@df93b608790c /]# rpm -q libmodulemd dnf python3-module package libmodulemd is not installed dnf-2.7.5-8.fc28.noarch package python3-module is not installed [root@df93b608790c /]# dnf update -y --best Last metadata expiration check: 0:03:46 ago on Thu Mar 15 13:12:38 2018. Error: Problem: package python3-dnf-2.7.5-8.fc28.noarch requires python3-modulemd, but none of the providers can be installed - package libmodulemd-1.0.4-2.fc28.x86_64 obsoletes python3-modulemd < 1.3.4 provided by python3-modulemd-1.3.3-1.fc28.noarch - cannot install the best update candidate for package python3-modulemd-1.3.3-1.fc28.noarch - cannot install the best update candidate for package python3-dnf-2.7.5-8.fc28.noarch
There should probably be combined update with dnf