Comments

12 Comments

The error is from RHEL8 (currently 8.5). There is python38 as a module but apparently not pulled into transaction by dnf. Moreover module does not contain e.g. python38-evdev.

Once again, now formated:

Error:
 Problem: cannot install the best update candidate for package lutris-0.5.9.1-4.el8.x86_64
  - nothing provides python3.8dist(distro) needed by lutris-0.5.10-1.el8.x86_64
  - nothing provides python3.8dist(evdev) needed by lutris-0.5.10-1.el8.x86_64
  - nothing provides python3.8dist(pygobject) needed by lutris-0.5.10-1.el8.x86_64
  - nothing provides python38-dbus needed by lutris-0.5.10-1.el8.x86_64
  - nothing provides python38-distro needed by lutris-0.5.10-1.el8.x86_64
  - nothing provides python38-evdev needed by lutris-0.5.10-1.el8.x86_64
  - nothing provides python38-gobject needed by lutris-0.5.10-1.el8.x86_64
  - nothing provides python38-pillow needed by lutris-0.5.10-1.el8.x86_64
(try to add '--nobest' to use not only best candidate packages)
karma

Upgrade failed:

Error: Problem: cannot install the best update candidate for package lutris-0.5.9.1-4.el8.x86_64 - nothing provides python3.8dist(distro) needed by lutris-0.5.10-1.el8.x86_64 - nothing provides python3.8dist(evdev) needed by lutris-0.5.10-1.el8.x86_64 - nothing provides python3.8dist(pygobject) needed by lutris-0.5.10-1.el8.x86_64 - nothing provides python38-dbus needed by lutris-0.5.10-1.el8.x86_64 - nothing provides python38-distro needed by lutris-0.5.10-1.el8.x86_64 - nothing provides python38-evdev needed by lutris-0.5.10-1.el8.x86_64 - nothing provides python38-gobject needed by lutris-0.5.10-1.el8.x86_64 - nothing provides python38-pillow needed by lutris-0.5.10-1.el8.x86_64 (try to add '--nobest' to use not only best candidate packages)

karma

Once again with formatting; It breaks RHEL8:

$ sudo dnf update
Updating Subscription Management repositories.
Error: 
 Problem: cannot install the best update candidate for package python3-GitPython-2.1.11-3.el8.noarch
  - nothing provides python3-gitdb >= 4.0.0 needed by python3-GitPython-3.1.0-1.el8.noarch
  - nothing provides python3.6dist(gitdb) >= 4.0.1 needed by python3-GitPython-3.1.0-1.el8.noarch
  - nothing provides python3.6dist(gitdb) < 5 needed by python3-GitPython-3.1.0-1.el8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
$ sudo dnf list python3-gitdb 
Updating Subscription Management repositories.
Installed Packages
python3-gitdb.noarch                                   2.0.3-6.el8                                   @epel
karma

Broken upgrade on RHEL8:

$ sudo dnf update Updating Subscription Management repositories. Error: Problem: cannot install the best update candidate for package python3-GitPython-2.1.11-3.el8.noarch - nothing provides python3-gitdb >= 4.0.0 needed by python3-GitPython-3.1.0-1.el8.noarch - nothing provides python3.6dist(gitdb) >= 4.0.1 needed by python3-GitPython-3.1.0-1.el8.noarch - nothing provides python3.6dist(gitdb) < 5 needed by python3-GitPython-3.1.0-1.el8.noarch (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages) $ sudo dnf list python3-gitdb Installed Packages python3-gitdb.noarch 2.0.3-6.el8 @epel

BZ#1501802 nothing provides python2-backports needed by python2-backports-functools_lru_cache-1.4-3.fc27.noarch
karma

koji resubmit 230210 Resubmitting the following task: TypeError: can't multiply sequence by non-int of type 'str'

after update from stable

Works fine. Thanks.

works