Comments

69 Comments
karma

fedpkg --branches is working for rawhide .

karma

At least dependency issue is resolved.

karma

Okay, now upgrade succeeds.

BZ#1903222 efl missing version is causing problems on attempts to update libavif
karma
 Problem: package libabigail-fedora-1.7-2.fc33.x86_64 requires libabigail(x86-64) = 1.7-2.fc33, but none of the providers can be installed
  - cannot install both libabigail-1.8-1.fc33.x86_64 and libabigail-1.7-2.fc33.x86_64
  - cannot install both libabigail-1.7-2.fc33.x86_64 and libabigail-1.8-1.fc33.x86_64
  - cannot install the best update candidate for package libabigail-fedora-1.7-2.fc33.x86_64
  - cannot install the best update candidate for package libabigail-1.7-2.fc33.x86_64

So we should really handle efl v.s libavif dependency error. Currently (although I am not maintainer for efl or for libavif, ) I am for disabling libavif support on elf. Everyone, how do you think?

As efl upstream seems slow for fixing FTBFS for libavif 0.8.2, perhaps it is better we drop libavif support from efl for now. @spot , ideas?

For the issue that efl 1.25.1 cannot be built with libavif 0.8.2, I've reported efl upstream: https://phab.enlightenment.org/T8844

For rawhide, I've once disabled libavif support for efl: efl-1.25.1-3.fc34

Tryin adding positive karma?

Broken a lot. Even when opening a new tab, new tab shows some error. gmail, slack cannot be seen. chrome://settings/ cannot be seen either.

karma

Unless this LXDE F31 live is broken.

I see some similar issue here. When I try changing the resolution of a laptop display with xrandr, the display gets black and never get back.

karma

#1707223 is now fixed, thank you.

BZ#1707223 fedpkg co --branches fails with 1.37
karma

Unfortunately already pushed into stable, however fedpkg co --branches does not work. Filed as #1707223

karma

Still fails:

 問題 1: package samba-dc-libs-2:4.10.2-1.fc30.x86_64 requires libkadm5srv_mit.so.11()(64bit), but none of the providers can be installed
  - package samba-dc-libs-2:4.10.2-1.fc30.x86_64 requires libkadm5srv_mit.so.11(kadm5srv_mit_11_MIT)(64bit), but none of the providers can be installed
  - cannot install both libkadm5-1.17-14.fc30.x86_64 and libkadm5-1.17-4.fc30.x86_64
  - cannot install both libkadm5-1.17-4.fc30.x86_64 and libkadm5-1.17-14.fc30.x86_64
  - cannot install the best update candidate for package samba-dc-libs-2:4.10.2-0.fc30.x86_64
  - cannot install the best update candidate for package libkadm5-1.17-4.fc30.x86_64

https://koji.fedoraproject.org/koji/buildinfo?buildID=1258877 , especially https://kojipkgs.fedoraproject.org//packages/samba/4.10.2/1.fc30/data/logs/x86_64/root.log says that samba-4.10.2-1.fc30 is rebuilt with krb5-devel-1.17-4.fc30.x86_64 , not -14.fc30. You have to submit override tag for krb5-1.17-14.fc30 and then rebuild samba.

I will advice to specify soversion explicitly in spec file.

karma
 Problem 1: package samba-dc-libs-2:4.10.2-0.fc30.x86_64 requires libkadm5srv_mit.so.11()(64bit), but none of the providers can be installed
  - package samba-dc-libs-2:4.10.2-0.fc30.x86_64 requires libkadm5srv_mit.so.11(kadm5srv_mit_11_MIT)(64bit), but none of the providers can be installed
  - cannot install both libkadm5-1.17-14.fc30.x86_64 and libkadm5-1.17-4.fc30.x86_64
  - cannot install both libkadm5-1.17-4.fc30.x86_64 and libkadm5-1.17-14.fc30.x86_64
  - cannot install the best update candidate for package samba-dc-libs-2:4.10.2-0.fc30.x86_64
  - cannot install the best update candidate for package libkadm5-1.17-4.fc30.x86_64
 Problem 2: problem with installed package samba-dc-libs-2:4.10.2-0.fc30.x86_64
  - package samba-dc-libs-2:4.10.2-0.fc30.x86_64 requires libkadm5srv_mit.so.11()(64bit), but none of the providers can be installed
  - package samba-dc-libs-2:4.10.2-0.fc30.x86_64 requires libkadm5srv_mit.so.11(kadm5srv_mit_11_MIT)(64bit), but none of the providers can be installed
  - cannot install both libkadm5-1.17-14.fc30.x86_64 and libkadm5-1.17-4.fc30.x86_64
  - cannot install both libkadm5-1.17-4.fc30.x86_64 and libkadm5-1.17-14.fc30.x86_64
  - package krb5-devel-1.17-14.fc30.x86_64 requires libkadm5(x86-64) = 1.17-14.fc30, but none of the providers can be installed
  - cannot install the best update candidate for package krb5-devel-1.17-4.fc30.x86_64
karma

Umm.. cannot understand what "works" means here... The above "Automated Tests" already complains about missing "perl(GitLab::API::v4::Constants)" dependency. And F-30 is broken as well.

# rpm -Fvh --test python2-configparser-3.7.1-1.fc29.noarch.rpm 
Verifying...                          ################################# [100%]
Preparing...                          ################################# [100%]
    file /usr/lib/python2.7/site-packages/backports/__init__.py from install of python2-configparser-3.7.1-1.fc29.noarch conflicts with file from package python2-backports-1.0-15.fc29.x86_64
    file /usr/lib/python2.7/site-packages/backports/__init__.pyc from install of python2-configparser-3.7.1-1.fc29.noarch conflicts with file from package python2-backports-1.0-15.fc29.x86_64
    file /usr/lib/python2.7/site-packages/backports/__init__.pyo from install of python2-configparser-3.7.1-1.fc29.noarch conflicts with file from package python2-backports-1.0-15.fc29.x86_64

F-30 is broken as well.

So bodhi can accept positive karma from those who edited the update?