Comments

292 Comments

re-rebuild needed for libarrow 15.0.2-2.fc41 reverted ABI break

/usr/bin/ld: /usr/lib64/libgdal.so.34: undefined reference to `arrow::KeyValueMetadata::Get[abi:cxx11](std::basic_string_view<char, std::char_traits<char> >) const'
/usr/bin/ld: /usr/lib64/libgdal.so.34: undefined reference to `arrow::KeyValueMetadata::Contains(std::basic_string_view<char, std::char_traits<char> >) const'
collect2: error: ld returned 1 exit status

error with gdal-3.8.4-4.fc41 and libarrow 15.0.2-2.fc41

Looks like this update broke gdal package which needs rebuild

/usr/bin/ld: /usr/lib64/libgdal.so.34: undefined reference to `arrow::KeyValueMetadata::Contains(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) const'
/usr/bin/ld: /usr/lib64/libgdal.so.34: undefined reference to `arrow::KeyValueMetadata::Get(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) const'
karma

Fixes problem with dbus-broker-34-1.fc39

karma
dbus-broker-launch[2128]: Exiting due to fatal error: -22
dbus-broker-launch[2128]:       main @ ../src/launch/main.c +178
dbus-broker-launch[2128]: Service file '/usr/share/dbus-1/services/org.kde.plasma.Notifications.service' is not named after the D-Bus name 'org.freedesktop.Notifications'.
dbus-broker-launch[2128]:       run @ ../src/launch/main.c +152
dbus-broker-launch[2128]:       launcher_run @ ../src/launch/launcher.c +1343
dbus-broker-launch[2128]:       launcher_load_services @ ../src/launch/launcher.c +974
dbus-broker-launch[2128]:       launcher_load_standard_session_services @ ../src/launch/launcher.c +918
dbus-broker-launch[2128]: ERROR launcher_load_service_dir @ ../src/launch/launcher.c +795: Invalid argument
dbus-broker-launch[2128]: Service file '/usr/share/dbus-1/services/org.kde.kscreen.service' is not named after the D-Bus name 'org.kde.KScreen'.
dbus-broker-launch[2128]: Service file '/usr/share/dbus-1/services/org.kde.dolphin.FileManager1.service' is not named after the D-Bus name 'org.freedesktop.FileManager1'.

No problem after downgrading to dbus-broker-33-2.fc39.x86_64

wget2-wget obsoletes wget aand makes impossible to install it. Is Will there be a way to install wget?

Upgrade failed because of conflicts.

  - file /etc/xdg/libkleopatrarc from install of libkleo-24.01.80-1.fc40.x86_64 conflicts with file from package kf5-libkleo-23.08.2-1.fc40.x86_64
  Problem 1: package kf5-akonadi-contacts-23.08.2-1.fc40.x86_64 requires libKPim5GrantleeTheme.so.5()(64bit), but none of the providers can be installed
  - package grantleetheme-24.01.80-1.fc40.x86_64 conflicts with kf5-grantleetheme < 24.01.75 provided by kf5-grantleetheme-23.08.2-1.fc40.x86_64
  - package grantleetheme-24.01.80-1.fc40.x86_64 obsoletes kf5-grantleetheme < 24.01.75 provided by kf5-grantleetheme-23.08.2-1.fc40.x86_64
  - cannot install the best update candidate for package kf5-grantleetheme-23.08.2-1.fc40.x86_64
  - cannot install the best update candidate for package kf5-akonadi-contacts-23.08.2-1.fc40.x86_64
 Problem 2: package kf5-pimcommon-23.08.2-1.fc40.x86_64 requires libKPim5AkonadiContact.so.5()(64bit), but none of the providers can be installed
  - package kf5-akonadi-contacts-23.08.2-1.fc40.x86_64 requires libKPim5GrantleeTheme.so.5()(64bit), but none of the providers can be installed
  - package grantleetheme-24.01.80-1.fc40.x86_64 conflicts with kf5-grantleetheme < 24.01.75 provided by kf5-grantleetheme-23.08.2-1.fc40.x86_64
  - package grantleetheme-24.01.80-1.fc40.x86_64 obsoletes kf5-grantleetheme < 24.01.75 provided by kf5-grantleetheme-23.08.2-1.fc40.x86_64
  - package akonadi-contacts-24.01.80-1.fc40.x86_64 requires libKPim6GrantleeTheme.so.6()(64bit), but none of the providers can be installed
  - package kgpg-24.01.80-1.fc40.x86_64 requires libKPim6AkonadiContactCore.so.6()(64bit), but none of the providers can be installed
  - package kgpg-24.01.80-1.fc40.x86_64 requires libKPim6AkonadiContactWidgets.so.6()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package kgpg-23.08.2-1.fc40.x86_64
  - cannot install the best update candidate for package kf5-pimcommon-23.08.2-1.fc40.x86_64
  Transaction failed: Rpm transaction failed.
  - file /usr/bin/akonadi_agent_launcher from install of akonadi-server-24.01.80-1.fc40.x86_64 conflicts with file from package kf5-akonadi-server-23.08.2-2.fc40.x86_64
  - file /usr/bin/akonadi_agent_server from install of akonadi-server-24.01.80-1.fc40.x86_64 conflicts with file from package kf5-akonadi-server-23.08.2-2.fc40.x86_64
  - file /usr/bin/akonadi_control from install of akonadi-server-24.01.80-1.fc40.x86_64 conflicts with file from package kf5-akonadi-server-23.08.2-2.fc40.x86_64
  - file /usr/bin/akonadi_knut_resource from install of akonadi-server-24.01.80-1.fc40.x86_64 conflicts with file from package kf5-akonadi-server-23.08.2-2.fc40.x86_64
  - file /usr/bin/akonadi_rds from install of akonadi-server-24.01.80-1.fc40.x86_64 conflicts with file from package kf5-akonadi-server-23.08.2-2.fc40.x86_64
  - file /usr/bin/akonadictl from install of akonadi-server-24.01.80-1.fc40.x86_64 conflicts with file from package kf5-akonadi-server-23.08.2-2.fc40.x86_64
  - file /usr/bin/akonadiserver from install of akonadi-server-24.01.80-1.fc40.x86_64 conflicts with file from package kf5-akonadi-server-23.08.2-2.fc40.x86_64

After removing conflicting packages kf5-libkleo kf5-akonadi-contacts kf5-akonadi-server I need to install removed kgpg kaddressbook kalarm kleopatra kmail. Package akonadi-server-mysql was not installed after that, akonadi server failed to start

org.kde.pim.akonadiserver: Starting up the Akonadi Server...
org.kde.pim.akonadiserver: Did not find MySQL server default configuration (mysql-global.conf)
org.kde.pim.akonadiserver: Shutting down AkonadiServer...

Works after installation of akonadi-server-mysql.

karma

No problems with chromium

karma

0001-pc-bios-optionrom-Fix-pvh.img-ld-build-failure-on-fe.patch broke el9 compilation

/usr/bin/ld: unrecognized option '--no-warn-rwx-segments'

BZ#2238900 Segmentation fault
BZ#2238900 Segmentation fault
BZ#2238900 Segmentation fault

chromium-119.0.6045.123-2.fc39 works fine with ffmpeg-libs-6.0.1-2.fc39.x86_64 which includes first_dts patch

package chromium-119.0.6045.159-1.fc39.x86_64 from updates-testing conflicts with ffmpeg-libs(x86-64) provided by ffmpeg-libs-6.0.1-2.fc39.x86_64

Works with ffmpeg-6.0.1-2.fc39.x86_64

chromium will forbid using RPMFusion?