Comments

24 Comments

There was a regression in lttng itself: https://github.com/redhat-developer/dotnet-regular-tests/issues/202

I dont think that should hold back the .NET update. I will waive tests.

I am waiving the test failures. 3 tests failed

  • template-test is looking for the recently added solution template (added in the September 2022 releases, this is the older one)
  • release-version-sane is failing because this is an already out of date release of .NET (August, upstream has September 2022 released)
  • lttng seems broken on Fedora 37. Needs more investigation, but not a regression.
BZ#2130913 Push F37 update to match other Fedora versions

Sorry, I can't.

.NET 7 RC 1 requires prebuilt binaries to build. That's not allowed in Fedora (see https://docs.fedoraproject.org/en-US/packaging-guidelines/what-can-be-packaged/#prebuilt-binaries-or-libraries). Upstream .NET maintainers are aware of this problem and we hope to get this fixed in 7.0 RC 2. I hope to add .NET 7 to Fedora once we can build RC 2, though it will need to undergo a package review since it's going to be a new package.

This update has been unpushed.

Used it to build and run a web application I am working on. No issues so far.

Everything looks okay here. I tried out some .NET Core command manually and didn't see any issues. I also ran the dotnet-regular-tests test suite and all tests passed.

karma

Everything looks okay here.

BZ#1831310 The documentation comments for the Base Class Library are missing
BZ#1843420 Update to 3.1.300 SDK and 3.1.4 runtime

This brings in https://github.com/djcb/mu/commit/6a294da2a1c094fae9a2f7150e26049d88e017a3 which also fixes the mu4e-main menu for me when evil-collection is used. For some reason I was not affected by BZ#1823325.

karma

Works for me!

karma

Can't even install this since it has hit stable:

$ sudo dnf upgrade --advisory=FEDORA-2019-0937bbf558
 Problem 1: cannot install the best update candidate for package podman-2:1.3.1-1.git7210727.fc30.x86_64
  - nothing provides containernetworking-plugins >= 0.7.5-1 needed by podman-2:1.4.0-1.fc30.x86_64
 Problem 2: package podman-docker-2:1.4.0-1.fc30.noarch requires podman = 2:1.4.0-1.fc30, but none of the providers ca
n be installed
  - cannot install the best update candidate for package podman-docker-2:1.3.1-1.git7210727.fc30.noarch
  - nothing provides containernetworking-plugins >= 0.7.5-1 needed by podman-2:1.4.0-1.fc30.x86_64
======================================================================================================================
 Package                       Architecture           Version                           Repository               Size
======================================================================================================================
Skipping packages with broken dependencies:
 podman                        x86_64                 2:1.4.0-1.fc30                    updates                  11 M
 podman-docker                 noarch                 2:1.4.0-1.fc30                    updates                  46 k

Transaction Summary
======================================================================================================================
Skip  2 Packages
Nothing to do.
karma

Works for me.

Thanks for the quick fix!

BZ#1461984 Build openjfx on i686
karma

I no longer get the build error in OpenJDK 9.

BZ#1439914 Unable to build OpenJDK 9 in Fedora 26

fixes virsh and virt-manager for me

BZ#1369284 libvirtd cannot start VMs: "SELinux denies access"

Works for me

BZ#1304117 Lettuce fails to run

Works for me.

karma

I can finally access bodhi using the python API again.

bellet, can you please file a bug to provide more details? This update resolves a number of serious security vulnerabilities and has already been pushed to stable. It is a bit too late to revert it, but if you can provide us with more information, we can try and fix this regression.