Comments

448 Comments
karma

Looks good here. Thanks for the update.

Note that there may be other non-packaged users of armadillo out there - it's generally frowned upon to break ABI in EPEL if possible to avoid it.

karma

This needs to be bundled with a scorep update:

Error: Package: scorep-libs-1.4.2-7.el7.x86_64 (@epel-7-x86_64/7.5)
           Requires: libcubewriter4.so.7()(64bit)
           Removing: cube-libs-4.3.2-3.el7.x86_64 (@epel-7-x86_64/7.5)
               libcubewriter4.so.7()(64bit)
           Updated By: cube-libs-4.4.4-1.el7.x86_64 (epel-testing)
               Not found
karma

Breaks ABI:

Error: Package: gdal-libs-1.11.4-3.el7.x86_64 (@epel-7-x86_64/7.5)
           Requires: libarmadillo.so.8()(64bit)
           Removing: armadillo-8.300.0-1.el7.x86_64 (@epel-7-x86_64/7.5)
               libarmadillo.so.8()(64bit)
           Updated By: armadillo-9.600.6-1.el7.x86_64 (epel-testing)
              ~libarmadillo.so.9()(64bit)

Thanks for fixing the sonames. However I don't really have a way of testing much else.

It's fine to have the -devel packages with the unversioned .so files conflict (which they should be explicit about). You're removing an existing soname from EL7 which should be avoided if possible, which it is.

karma

Still broken because sundials2 provides names like 'libsundials2_nvecserial.so.2()(64bit)' instead of 'libsundials_nvecserial.so.2()(64bit)'.

Error: Package: 6:octave-4.4.1-1.el7.x86_64 (@group_scitech-octave4.4)
           Requires: libsundials_nvecserial.so.2()(64bit)
           Removing: sundials-2.7.0-10.el7.x86_64 (@epel)
               libsundials_nvecserial.so.2()(64bit)
           Obsoleted By: sundials2-2.7.0-1.el7.x86_64 (epel-testing)
              ~libsundials2_nvecserial.so.2()(64bit)
Error: Package: 6:octave-4.4.1-1.el7.x86_64 (@group_scitech-octave4.4)
           Requires: libsundials_ida.so.2()(64bit)
           Removing: sundials-2.7.0-10.el7.x86_64 (@epel)
               libsundials_ida.so.2()(64bit)
           Obsoleted By: sundials2-2.7.0-1.el7.x86_64 (epel-testing)
              ~libsundials2_ida.so.2()(64bit)

```

Works for me

karma

Works here. Thanks.

That suricata build was done with libprelude 4.1.0, no 5.0.0

Still missing a suricata rebuild

Just a heads up to mitogen users - be aware that mitogen does not yet work with ansible 2.8.

karma

LGTM

BZ#1705706 install of amanda client fails with nothing provides libreadline.so.7()(64bit)
karma

LGTM

BZ#1700058 [RFE] Systematic Provides: python3-%{name} on el7

My guess is an out of date mirror. Hopefully it will sync up soon.

Looks like you don't have python3*-pycurl installed then. To install:

yum --enablerepo=epel-testing install python34-pycurl python36-pycurl
karma

WFM

BZ#1693011 clamav-0.101.2 is available
User Icon orion commented & provided feedback on koji-1.17.0-5.el7 4 years ago
karma

It appears that the problem was an old ~/.koji/serverca.crt file that apparently was previously being ignored but now is not. I'm not sure if that is expected behavior or not. Removing the file allows it to work.