Comments

85 Comments

GeoIP in Fedora 22 onwards doesn't need to depend of geoipupdate, for the reasons you specified. However, everywhere else has already shipped a GeoIP that includes geoipupdate (and the libGeoIPUpdate library) so as per the stable release updates policy, any GeoIP update there needs to include the geoipupdate stuff, either included or as a dependency, so as not to break anything on end user systems.

karma

This can't be pushed to a stable release as-is because it doesn't contain the geoipupdate stuff and would break things for anyone that uses it. Needs to wait until the new geoipupdate package is ready, and have a dependency on it.

This helps, thanks.

perl-autodie builds and runs fine using this.

Local build of perl-Params-Classify works with this.

Local build of perl-Package-Stash-XS using this package passes its test suite

Local build of perl-Pod-Coverage-TrustPod passes test suite with this package.

This update has been submitted for stable.

This update has been submitted for testing.

This update has been submitted for testing.

This update has been submitted for testing.

This update has been submitted for stable.

This update has been submitted for testing.

This update has been submitted for stable.

This update has been submitted for testing.

This update has been submitted for stable.

This update has been submitted for testing.

This update has been submitted for testing.

This update has been submitted for stable.

This update has been submitted for stable.