The update is not installable:
$ sudo dnf --enablerepo=updates-testing update usbguard\* Dependencies resolved. Problem: usbguard-0.7.2-8.fc31.i686 has inferior architecture - package usbguard-applet-qt-0.7.2-8.fc31.x86_64 requires usbguard = 0.7.2-8.fc31, but none of the providers can be installed - cannot install both usbguard-0.7.6-4.fc31.x86_64 and usbguard-0.7.2-8.fc31.x86_64 - cannot install both usbguard-0.7.2-8.fc31.x86_64 and usbguard-0.7.6-4.fc31.x86_64 - cannot install the best update candidate for package usbguard-applet-qt-0.7.2-8.fc31.x86_64 - cannot install the best update candidate for package usbguard-0.7.2-8.fc31.x86_64 ======================================================================================================================== Package Architecture Version Repository Size ======================================================================================================================== Skipping packages with conflicts: (add '--best --allowerasing' to command line to force their upgrade): usbguard x86_64 0.7.6-4.fc31 updates-testing 549 k Transaction Summary ======================================================================================================================== Skip 1 Package Nothing to do. Complete!
You should add
Obsoletes: usbguard-applet-qt < 0.7.6-4 to the spec file.
Thanks, I totally missed it as there was nothing about it in the changelog and it was a micro version bump. I opened a bug upstream to complain: https://code.videolan.org/videolan/libdvdread/issues/9 .
@robatino thanks for the notice. You're right, the version in
manifest.json is 1.22.0 still. It looks like upstream forgot to update it when releasing 1.22.2, which seems plausible given that it's an emergency fix release. I've just reported this upstream.
I will update noscript within the next few days.