Comments

177 Comments
karma

I've been using it since Dec 19th, no issues.

This update has been unpushed.

karma

The update is not installable:

$ sudo dnf --enablerepo=updates-testing update usbguard\*
Dependencies resolved.

 Problem: usbguard-0.7.2-8.fc31.i686 has inferior architecture
  - package usbguard-applet-qt-0.7.2-8.fc31.x86_64 requires usbguard = 0.7.2-8.fc31, but none of the providers can be installed
  - cannot install both usbguard-0.7.6-4.fc31.x86_64 and usbguard-0.7.2-8.fc31.x86_64
  - cannot install both usbguard-0.7.2-8.fc31.x86_64 and usbguard-0.7.6-4.fc31.x86_64
  - cannot install the best update candidate for package usbguard-applet-qt-0.7.2-8.fc31.x86_64
  - cannot install the best update candidate for package usbguard-0.7.2-8.fc31.x86_64
========================================================================================================================
 Package                   Architecture            Version                       Repository                        Size
========================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 usbguard                  x86_64                  0.7.6-4.fc31                  updates-testing                  549 k

Transaction Summary
========================================================================================================================
Skip  1 Package

Nothing to do.
Complete!

You should add Obsoletes: usbguard-applet-qt < 0.7.6-4 to the spec file.

#1763148 is still not fixed in this update. Is #1773357 even relevant for F30?

BZ#1763148 thinkfan: /etc/sysconfig/thinkfan is not used

libdvdread ABI bump was reverted, so this is good to go

Thanks, I totally missed it as there was nothing about it in the changelog and it was a micro version bump. I opened a bug upstream to complain: https://code.videolan.org/videolan/libdvdread/issues/9 .

karma

Got bitten by #1757948 and this update fixes it for me.

Actually, it looks like it was my mistake, I got the 1.22.0 XPI file instead of 1.22.2. I'll fix this shortly.

@robatino thanks for the notice. You're right, the version in manifest.json is 1.22.0 still. It looks like upstream forgot to update it when releasing 1.22.2, which seems plausible given that it's an emergency fix release. I've just reported this upstream.

I will update noscript within the next few days.

Doesn't crash on startup like -2 did. Works for me.

Crashing upon start up here as well.

This is crashing for me as well.

Fixes the conflict for me, thanks.

BZ#1696118 /bin/oc conflicts with binary from the origin-clients package

Works for me on a Haswell laptop and a VM.

Works for me on a Haswell laptop and a VM.

karma

Sorry, this was broken in the previous update. This one is no worse that the previous one.

BZ#1697662 /etc/httpd/state: broken symbolic link to ../../var/lib/httpd/state (supplied by httpd-2.4.39-2.fc29.x86_64)
karma

Sorry, this was broken in the previous update. This one is no worse that the previous one.