Comments

263 Comments

Why is there no mention of a switching from libidn to libidn2 since 3.5.8 in the release notes?

I see. That's the kind of information that would be extremely valuable in the release notes. Please make sure you include it next time your update adds new dependencies. Thanks.

What kind of update description is this? Come on... Also, you haven't explained or even mentioned the new dependency on libfastjson. So now I have two json libraries on my system where I had just one before (json-c is still required by abrt, so I can't remove it). And no, the argument that it takes just 56KB on disk isn't valid. Now, I did find out that upstream switched from any json-c compatible library to libfastjson on 2016-02-03, but the point is I shouldn't have to figure out why there's a new dependency on my own. Not to mention that introducing new dependencies is against stable updates policy. As is jumping from 8.12 to 8.24. It seems like a big change which should be avoided in N-1 stable release unless there's a good reason. I don't see any.

Works for me, no regressions noted and the required dependency is in place.

BZ#1395714 perl-Net-Server should depend on perl-IO-Socket-INET6

It seems mock grew a dependency on SMTP daemon and redhat-lsb-core (due to a new dependency on python3-distro), which is not documented in the package changelog or the release notes above. Please explain why I have to have an MTA installed on a development machine? This update pulls in 8 new packages in total without any explanation:

ed
m4
python3-distro
redhat-lsb-core
redhat-lsb-submod-security
spax
(something providing smtpdaemon)
util-linux-user

Please note that the corresponding hplip-plugin is not available yet, so this update breaks printing for all printers which require it. I reported (another) bug upstream: https://bugs.launchpad.net/fedora/+source/hplip/+bug/1644932 .

Please note that the corresponding hplip-plugin is not available yet, so this update breaks printing for all printers which require it. I reported (another) bug upstream: https://bugs.launchpad.net/fedora/+source/hplip/+bug/1644932 .

According to https://wiki.mozilla.org/Electrolysis , e10s on FF50 is supported with extensions marked as "multiProcessCompatible", which ABP 2.9.5.1 does have in install.rdf, so.. a bug in Firefox, perhaps? Thanks for testing!

Sorry, it was wrong of me to give negative karma here. The applet looks a bit different (the icon looks different and the menu is a bit smaller), but functionally the same. However, the issue of adding 19 packages of dependencies in the middle of stable release lifecycle remains.

karma

Hold on. Switching to a different (Qt5) UI library (= changing user experience) is against stable updates policy. Also, this drags in additional 19 packages which I didn't have to install before. This is not acceptable without good justification. Saying that "The firewall applet has been ported from Qt4 to Qt5." is not a justification at all.

karma

Works for me and fixes the bug, thanks.

BZ#1361815 blank output from dnssort tool

After removing local modifications and restarting tor, I don't see any AVC alerts.

BZ#1368621 SELinux is preventing (tor) from 'mounton' accesses on the directory /run/tor.
BZ#1357395 Couple of SELinux alerts for Tor
karma

Sorry for not catching this earlier, but hplip-plugin-3.16.9 is not available, so this breaks printing for me again. Could you add a check for existence of the corresponding hplip-plugin version to your update workflow? http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.16.9-plugin.run in this case. Bug reported upstream as well: https://bugs.launchpad.net/hplip/+bug/1630028 .

Works for me (i.e. for building python-colorspacious), please push to stable.

Works for me and includes upstream fix for: https://github.com/rg3/youtube-dl/issues/7799 .

BZ#1359464 youtube-dl-2016.09.15 is available

@dhgutteridge, it looks like they fixed the missing plugin issue, so it should work now.

Please note that the corresponding hp-plugin 3.16.8 is not available for download yet, so this will break any printer that requires the plugin. See https://bugs.launchpad.net/hplip/+bug/1618851 .