Comments

253 Comments

Bug #2041481 is closed as duplicate of bug #2039093.

This one is good. No dependency issues and -braille subpackage can be uninstalled along with its liblouis deps.

BZ#2040973 Make Braille printing support optional

It's not installable:

Error: 
 Problem: conflicting requests
  - nothing provides cups-filters{?_isa} = 1.28.10-3.fc35 needed by cups-filters-braille-1.28.10-3.fc35.x86_64

I guess you made a typo (missing %) in cups-filters.spec:139. Same as in rawhide.

@fuller this is the wrong update to give karma. This one is not installable. You should have given -1 here before it went to stable. You can give +1 to FEDORA-EPEL-2022-f65a1a9d86 instead.

Looks like xlib got updated to 0.31, so that's no longer an issue. I made a build with the deps on pyyaml and psutils lowered to match RHEL8. Please try it: https://koji.fedoraproject.org/koji/taskinfo?taskID=81137219 .

karma

Seems to work fine on my desktop (Intel IvyBridge with AMD TAHITI GPU). Apparently fixes bug #2012882. Bug #2025345 is also fixed in 5.15.x series on my Dell XPS 15 laptop (Intel SandyBridge with nVidia GT525M GPU).

karma

Not installable:

# dnf update
Last metadata expiration check: 0:07:39 ago on Wed 01 Dec 2021 09:27:00 CET.
Error: 
 Problem 1: package libheif-1.12.0-2.fc35.x86_64 requires libjxl.so.0()(64bit), but none of the providers can be installed
  - cannot install both libjxl-0.6.1-6.fc35.x86_64 and libjxl-0.5-3.fc35.x86_64
  - cannot install the best update candidate for package libjxl-0.5-3.fc35.x86_64
  - cannot install the best update candidate for package libheif-1.12.0-2.fc35.x86_64
 Problem 2: package gimp-heif-plugin-1.1.0-10.fc35.x86_64 requires libheif.so.1()(64bit), but none of the providers can be installed
  - package libheif-1.12.0-2.fc35.x86_64 requires libjxl.so.0()(64bit), but none of the providers can be installed
  - cannot install both libjxl-0.6.1-6.fc35.x86_64 and libjxl-0.5-3.fc35.x86_64
  - package jxl-pixbuf-loader-0.6.1-6.fc35.x86_64 requires libjxl.so.0.6()(64bit), but none of the providers can be installed
  - package jxl-pixbuf-loader-0.6.1-6.fc35.x86_64 requires libjxl.so.0.6(JXL_0)(64bit), but none of the providers can be installed
  - package jxl-pixbuf-loader-0.6.1-6.fc35.x86_64 requires libjxl_threads.so.0.6()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package jxl-pixbuf-loader-0.5-3.fc35.x86_64
  - cannot install the best update candidate for package gimp-heif-plugin-1.1.0-10.fc35.x86_64
 Problem 3: problem with installed package libheif-1.12.0-2.fc35.x86_64
  - package libheif-1.12.0-2.fc35.x86_64 requires libjxl.so.0()(64bit), but none of the providers can be installed
  - cannot install both libjxl-0.6.1-6.fc35.x86_64 and libjxl-0.5-3.fc35.x86_64
  - package libaom-3.2.0-2.fc35.x86_64 requires libjxl.so.0.6()(64bit), but none of the providers can be installed
  - package libaom-3.2.0-2.fc35.x86_64 requires libjxl.so.0.6(JXL_0)(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package libaom-3.1.2-1.fc35.x86_64
 Problem 4: problem with installed package gimp-heif-plugin-1.1.0-10.fc35.x86_64
  - package gimp-heif-plugin-1.1.0-10.fc35.x86_64 requires libheif.so.1()(64bit), but none of the providers can be installed
  - package libheif-1.12.0-2.fc35.x86_64 requires libjxl.so.0()(64bit), but none of the providers can be installed
  - cannot install both libjxl-0.6.1-6.fc35.x86_64 and libjxl-0.5-3.fc35.x86_64
  - libjxl-0.6.1-6.fc35.i686 has inferior architecture
  - cannot install the best update candidate for package libjxl-0.5-3.fc35.i686
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Does this mean one should flash this uboot version to SPI on a Pinebook Pro to receive the fix?

karma

I haven't noticed the issue because I was setting LIBVA_DRIVER_NAME to i965 in my .bash_profile explicitly. However, after unsetting it, the issue did occur and this update fixes it. Thanks!

karma

Confirmed, the missing dependency is there now.

BZ#2020792 libusb missing dependency on libusb1

The boolean dependency is wrong, in general. Having libwayland-client installed doesn't imply you're actually running a Wayland session. There is no way to express such runtime environment dependency in RPM. Instead, I suggest adding Recommends: on both xclip and wl-clipboard so that either can be uninstalled if not necessary.

In my case, I'm running MATE (Xorg only), but libwayland-client is a dependency of many essential packages (e.g. gtk3, mesa and others, so it's installed but unused.

This version is too new for kernel 5.14.x:

[   16.633984] sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: version 1:9:0-fa857
[   16.633991] sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:19:0 Kernel ABI 3:18:0
[   16.633994] sof-audio-pci-intel-tgl 0000:00:1f.3: warn: FW ABI is more recent than kernel
[   16.634007] sof-audio-pci-intel-tgl 0000:00:1f.3: unknown sof_ext_man header type 3 size 0x30
[   16.730626] sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: version 1:9:0-fa857
[   16.730634] sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:19:0 Kernel ABI 3:18:0
[   16.730637] sof-audio-pci-intel-tgl 0000:00:1f.3: warn: FW ABI is more recent than kernel
[   17.106815] sof-audio-pci-intel-tgl 0000:00:1f.3: Topology: ABI 3:19:0 Kernel ABI 3:18:0
[   17.106823] sof-audio-pci-intel-tgl 0000:00:1f.3: warn: topology ABI is more recent than kernel

Downgrading back to 1.8 helps.

Indeed, -1 build is broken, but -3 works.

BZ#2017015 rust-zram-generator-1.0.1 is available
BZ#2017497 Failed to start Create swap on /dev/zram0 with zram-generator-1.0.1-1.fc35

@pbrobinson thanks for catching this. Fixed in -7.

Fixes mock -r fedora-rawhide-x86_64-rpmfusion_free for me, thanks!

BZ#2007929 Absent GPG KEY for rpmfusion Rawhide

Tested and seems to work. The Makefile generated by qmake6 no longer contains rpath.

BZ#1982699 qmake6 generated Makefile introduces standard rpath

New build works for me (Tahiti), but Fedora CFLAGS are still not being used during build: https://kojipkgs.fedoraproject.org//packages/radeontop/1.3.post4/3g1552170.fc34/data/logs/x86_64/build.log

...
+ /usr/bin/make -O -j6 V=1 VERBOSE=1
cc -Os -Wall -Wextra -pthread -Iinclude -ffunction-sections -fdata-sections  -I/usr/include/libdrm -I/usr/include/valgrind   -DENABLE_XCB=1 -D_DEFAULT_SOURCE -D_XOPEN_SOURCE=600  -DENABLE_NLS=1 -DHAS_DRMGETDEVICE=1 -DENABLE_AMDGPU=1 -DHAS_AMDGPU_QUERY_SENSOR_INFO=1 -s   -c -o auth.o auth.c

The binary doesn't get rebuilt in %install any more, so at least there's some progress. :)

BZ#1909558 radeontop doesn't use Fedora CFLAGS and gets built again in %install
karma

Works and fixes the panfrost page faults on Pinebook Pro.

BZ#1965784 [PineBook Pro] panfrost ff9a0000.gpu: Unhandled Page fault in AS0 at VA 0x0000000015600000