Comments

349 Comments
BZ#2144669 Please build vokoscreenNG for EPEL 9
BZ#2144660 Please build OpenSceneGraph for EPEL 9
BZ#2147357 Please build liblas for EPEL 9

Thank you for the confirmation and thank you also for pointing out this issue!

@mikelo2, however this "only" breaks build-time, not run-time, correct?

@mikelo2, however this "only" breaks build-time, not run-time, correct?

Works as expected on RHEL 8.7 and unbreaks the situation.

BZ#2144202 Problem: package libknet1-compress-bzip2-plugin-1.24-3.1.el8.x86_64 requires libknet1(x86-64) = 1.22-2.el8_6, but none of the providers can be installed

This update breaks (update to) RHEL 8.7 with HA AddOn:

 libknet1                                                                 x86_64                                           1.24-2.el8                                                  rhel-8-for-x86_64-highavailability-rpms                                            81 k
 libknet1-compress-bzip2-plugin                                           x86_64                                           1.24-2.el8                                                  rhel-8-for-x86_64-highavailability-rpms                                            15 k
 libknet1-compress-lz4-plugin                                             x86_64                                           1.24-2.el8                                                  rhel-8-for-x86_64-highavailability-rpms                                            17 k
 libknet1-compress-lzma-plugin                                            x86_64                                           1.24-2.el8                                                  rhel-8-for-x86_64-highavailability-rpms                                            15 k
 libknet1-compress-lzo2-plugin                                            x86_64                                           1.24-2.el8                                                  rhel-8-for-x86_64-highavailability-rpms                                            16 k
 libknet1-compress-plugins-all                                            x86_64                                           1.24-2.el8                                                  rhel-8-for-x86_64-highavailability-rpms                                            11 k
 libknet1-compress-zlib-plugin                                            x86_64                                           1.24-2.el8                                                  rhel-8-for-x86_64-highavailability-rpms                                            15 k
 libknet1-crypto-nss-plugin                                               x86_64                                           1.24-2.el8                                                  rhel-8-for-x86_64-highavailability-rpms                                            20 k
 libknet1-crypto-openssl-plugin                                           x86_64                                           1.24-2.el8                                                  rhel-8-for-x86_64-highavailability-rpms                                            18 k
 libknet1-crypto-plugins-all                                              x86_64                                           1.24-2.el8                                                  rhel-8-for-x86_64-highavailability-rpms                                            11 k
 libknet1-plugins-all                                                     x86_64                                           1.24-2.el8                                                  rhel-8-for-x86_64-highavailability-rpms                                            11 k

Thus this currently leads on RHEL 8.7 to this:

dnf update
Updating Subscription Management repositories.
Last metadata expiration check: 1:17:34 ago on Wed Nov 23 15:03:55 2022.
Error: 
 Problem 1: package libknet1-compress-bzip2-plugin-1.24-3.1.el8.x86_64 requires libknet1(x86-64) = 1.22-2.el8_6, but none of the providers can be installed
  - cannot install both libknet1-1.22-2.el8_6.x86_64 and libknet1-1.24-2.el8.x86_64
  - cannot install the best update candidate for package libknet1-compress-bzip2-plugin-1.24-2.el8.x86_64
  - cannot install the best update candidate for package libknet1-1.24-2.el8.x86_64
 Problem 2: package libknet1-compress-bzip2-plugin-1.24-3.1.el8.x86_64 requires libknet1(x86-64) = 1.22-2.el8_6, but none of the providers can be installed
  - cannot install both libknet1-1.24-2.el8.x86_64 and libknet1-1.22-2.el8_6.x86_64
  - problem with installed package libknet1-1.24-2.el8.x86_64
  - cannot install both libknet1-1.22-2.el8_6.x86_64 and libknet1-1.24-2.el8.x86_64
  - package libknet1-compress-plugins-all-1.24-3.1.el8.x86_64 requires libknet1-compress-bzip2-plugin(x86-64) = 1.24-3.1.el8, but none of the providers can be installed
  - cannot install the best update candidate for package libknet1-compress-plugins-all-1.24-2.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
BZ#2128674 Problem: package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64 requires libknet1(x86-64) = 1.22-1.el8, but none of the providers can be installed
BZ#2142699 Please build perl-Lchown for EPEL 9
BZ#2139150 [Major Incident] CVE-2022-3602 openssl3: OpenSSL: X.509 Email Address Buffer Overflow [epel-all]
BZ#2139152 CVE-2022-3786 openssl3: OpenSSL: X.509 Email Address Variable Length Buffer Overflow [epel-all]

Thank you, this fixes building packages for RHEL 6

karma

I'm the baresip package maintainer. The issue is triggered by pipewire-0.3.58-2.fc36, but works fine with pipewire-0.3.58-1.fc36. If this should be a bug in baresip from your point of view, please let me (and/or baresip upstream) know what's wrong technically.

BZ#2091121 rubygem-rack-2.2.4 is available
BZ#2113698 rubygem-rack: FTBFS in Fedora rawhide/f37

As already discussed on IRC, the suggested workaround does unfortunately not work.

karma

Satisfies the dependency, thank you!

BZ#2109823 Please build im-chooser for EPEL 9

Update unfortunately breaks building packages for RHEL 6…

Mock Version: 3.1
ENTER ['do_with_status'](['bash', '--login', '-c', '/usr/bin/rpmbuild -bs --noclean --target x86_64 --nodeps /builddir/build/SPECS/example.spec'], chrootPath='/var/lib/mock/centos+epel-6-x86_64-example/root'env={'TERM': 'vt100', 'SHELL': '/bin/bash', 'HOME': '/builddir', 'HOSTNAME': 'mock', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'PS1': '<mock-chroot> \\s-\\v\\$ ', 'LANG': 'C.UTF-8'}shell=Falselogger=<mockbuild.trace_decorator.getLog object at 0x7f714f793ba8>timeout=0uid=1000gid=135user='mockbuild'nspawn_args=[]unshare_net=TrueprintOutput=False)
Executing command: ['bash', '--login', '-c', '/usr/bin/rpmbuild -bs --noclean --target x86_64 --nodeps /builddir/build/SPECS/example.spec'] with env {'TERM': 'vt100', 'SHELL': '/bin/bash', 'HOME': '/builddir', 'HOSTNAME': 'mock', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'PS1': '<mock-chroot> \\s-\\v\\$ ', 'LANG': 'C.UTF-8'} and shell False
--noclean: unknown option
Child return code was: 1
EXCEPTION: [Error()]
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/mockbuild/trace_decorator.py", line 93, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.6/site-packages/mockbuild/util.py", line 598, in do_with_status
    raise exception.Error("Command failed: \n # %s\n%s" % (command, output), child.returncode)
mockbuild.exception.Error: Command failed: 
 # bash --login -c /usr/bin/rpmbuild -bs --noclean --target x86_64 --nodeps /builddir/build/SPECS/example.spec

Worked to build an install python-SecretStorage-3.3.1-5.el9

BZ#2108330 Please build python-jeepney for EPEL 9

LGTM :)

LGTM :)

karma

LGTM :)

LGTM :)