Comments

147 Comments

How does it make sense for there to be "cmake" and "cmake3" packages at the same time, when both are version 3?

It's clearly specified in https://bugzilla.redhat.com/show_bug.cgi?id=1756974

I don't know why they need to install all binaries with as 3 or use Provides: cmake3 = 3.11.4-3.el8, unless CMake-2 is still provided by CentOS 8.

This prevents any CMake additional updated package.

Yes, I know. But CMake-3.11 is too old for some of the packages I would like to have on CentOS 8, especially with respect to the support of Python 3 and Boost.Python.

I don't know if we can spread another CMake3-3* RPM on EPEL8 together original CMake-3* from CentOS 8. But i may provide to you a src-rpm for building it outside official repositories (like a dedicated Copr project).

CMake3 on EPEL7 is built against system's libarchive-3.1.2 and libzstd-1.4.4

No, sorry. libarchive is bundled in this release. CMake-3.17.1 needs libarchive >= 3.3.3

Just wondering how you got around the zstd support issue in libarchive?

CMake3 on EPEL7 is built against system's libarchive-3.1.2 and libzstd-1.4.4

Will you make it available on EPEL 8 too?

Appstream repositories already provide CMake-3.11.4

This update has been unpushed.

avogadro2-libs-1.93.0-3.fc32 ? That error was fixed with avogadro2-libs-1.93.0-4.fc32, it's among these updates...

This comment is wrong. Sorry.

I meant the error was fixed with release avogadro2-libs-1.93.0-3; it's working on F31 and on mock-F32-root. So, i don't understand why does not work for you.

avogadro2-libs-1.93.0-3.fc32 ?

That error was fixed with avogadro2-libs-1.93.0-4.fc32, it's among these updates...

Your last suggestion has been illuminating. Thanks.

This update has been unpushed.

This update has been unpushed.

I can reproduce this issue on Fedora+Wayland. Thanks for reporting.

This update has been unpushed.

Sorry, i don't understand:

in this comment you wrote

Additional info:
qcad trial is up & running:

Version: 3.24.2.0 (3.24.2)
Internet: QCAD.org
Build Date: Jan 10 2020
Revision: f05abb0
Qt Version: 5.8.0
Architecture: x86_64
Compiler: gcc 4.8.1

Have you compiled it by yourself?

Is it working?

GCC-4.8.1 on Fedora 31?

@enpontus

QCAD works for me with both Wayland and X11 on Fedora 3.

Make sure that qt5-qtbase-gui is installed.

Yes, MUMPS must be rebuilt for scalapack-2.1* changes. Thanks.

ImportError: libdmumps-5.2.so: cannot open shared object file: No such file or directory

Have you installed MUMPS-5.2.1-3.el7 and petsc-3.11.3-9.el7 ?