Comments

245 Comments

Both python36-petsc4py-openmpi and python2-petsc4py-openmpi were also missing Requires: MUMPS%{?_isa} which requirement at least rhel7 rpm can't find.

Ok. That is missing BR: MUMPS in petsc4py. dnf on build system can pull that in but epel7 version of mock which still uses yum on el7 based systems can't pull it in.

See MUMPS commit 4df584d935e06c4830ccfea555cef042d8de3ef8 - that includes changes which require scalapack-2.1.0 while epel7 still has scalapack-2.0.2 - Could this be the source for issues I see?

I see possible issue with petsc4py-3.11.0-11.el7 - I tried to rebuild it on mock and %check part fails with error:

I used default epel-7-x86_64.cfg with only modification being epel testing enabled for test build.

ImportError: libdmumps-5.2.so: cannot open shared object file: No such file or directory

karma

This update includes .so version bump breaking other software on epel7 so you are required to include all depending packages to the update.

package: mosquitto-1.6.8-1.el7.x86_64

unresolved deps:

 libwebsockets.so.13()(64bit)

package: qpid-dispatch-router-1.9.0-1.el7.x86_64

unresolved deps:

 libwebsockets.so.13()(64bit)
User Icon tis commented & provided feedback on elements-5.8-4.el7 2 years ago
karma

Oops - package is not installable because of wrong dependencies (for epel7).

package: elements-5.8-4.el7.x86_64

unresolved deps:

 cmake-filesystem(x86-64)
User Icon tis commented & provided feedback on drupal7-7.69-1.el7 2 years ago
karma

Unfortunately package is not installable on epel7 because of missing dependencies.

package: drupal7-7.68-1.el7.noarch

unresolved deps:

 php-ssh2
karma

Unfortunately this package is installable on epel6 because of missing dependencies:

package: drupal7-7.68-1.el6_10.noarch

unresolved deps:

 php-ssh2

This changes is required in two different places:

- Requires:       %{libname}%{?_isa} = %{version}-%{release}
+ Requires:       %{libname}%{?_isa} = %{epoch}:%{version}-%{release}
karma

When you add epoch, you need to add it to all dependencies too.

package: 1:libimagequant-devel-2.7.2-2.el7.x86_64

unresolved deps:

 libimagequant(x86-64) = 0:2.7.2-2.el7

package: 1:pngquant-2.7.2-2.el7.x86_64

unresolved deps:

 libimagequant(x86-64) = 0:2.7.2-2.el7

package: nagios-plugins-ssl_validity-2.3.1-1.el6_10.x86_64

unresolved deps:

 perl(Crypt::X509)
User Icon tis commented & provided feedback on soci-4.0.0-4.el7 2 years ago
karma

This again breaks all packages using libsoci. With controlled manner I meant more like: One update with all packages build against new soci. Not package by package so that updates cause breakage.

karma

rpm -q --requires -p python36-wxpython4-4.0.7-3.el7.x86_64.rpm | grep sip

python36-wx-siplib-api(%{_sip_api_major})(x86-64) >= %{_sip_api}

Something really badly wrong in packaging. Package is not installable.

BZ#1765572 Please package wxpython4 also for EPEL-7

Thunderbird just got updated to 68.2.0 - This update doesn't work with this current version...

User Icon tis commented & provided feedback on soci-4.0.0-2.el7 2 years ago
karma

First, this package has invalid dependencies:

package: soci-postgresql-devel-4.0.0-2.el7.x86_64

unresolved deps:

 libpq-devel

Package includes .so version bump which is only allowed if all dependencies are updated coordinated manner. Currently this breaks at least following packages:

travelccm-1.00.2-1.el7, trademgen-1.00.2-1.el7, simcrs-1.01.1-3.el7, simfqt-1.00.1-1.el7, sevmgr-1.00.2-1.el7, python3-opentrep-0.07.1-2.el7 (which btw is wrong package naming on epel7, should be python36-opentrep), opentrep-0.07.1-2.el7, airtsp-1.01.2-1.el7 and airinv-1.00.1-3.el7. I might have missed some.

User Icon tis commented & provided feedback on cjdns-20.4-2.el7 2 years ago
karma

Package is not epel7 compatible. Issues:

python3-cjdns sub-package is not correct naming on epel7 - should be python36-cjdns

cjdns-graph depens on python3-networkx - there is no such module on epel7. Actually there is no python36-networkx either, only python-networkx.

Actually that is caused by similar naming bug in python3-gssapi. So that need to be fixed first.

package: python3-urllib-gssapi-1.0.1-13.el6.noarch

unresolved deps:

 python34-gssapi

First. Package name is not ok on epel6. And dependencies are not available. Please disable build of python3 variant on epel6.

Oh. And that means there is nothing left to build - so better just pull this back.

BZ#1755010 RFE - build python-urllib-gssapi for epel
karma

package: python36-impacket-0.9.20-1.el7.noarch

unresolved deps:

 python36-flask

python-flask is in rhel7 so to get this dependency there python3-flask for epel7 would be needed.

If you check build log, build was done against epel7 python36 package, not python3 package which comes from rhel7.7.