Comments

245 Comments

I ment to say - going backwards in release won't work.

karma

epel7 already has gtk-sharp-2.99.3-16.el7 - why going backwards in release won't work.

User Icon tis commented & provided feedback on did-0.11-1.el7 3 years ago
karma

Bad dependency: python2-gssapi - package in rhel is python-gssapi.

I can't get this build successfully if golang-1.11.2-1.el7 is in build root. Was it intentional that there was golang-1.9.4-1.el7 in build root?

karma

This update obsoletes grib_api and grib_api-devel breaking following packages:

gdl-0.9.7-1.el7.x86_64 (requires libgrib_api.so.0()(64bit))
gdl-python-0.9.7-1.el7.x86_64 (requires libgrib_api.so.0()(64bit))
grib_api-static-1.12.3-5.el7.x86_64 ( Requires  grib_api(x86-64) = 0:1.12.3-5.el7, grib_api-devel(x86-64) = 0:1.12.3-5.el7)
python-grib_api-1.12.3-5.el7.x86_64 (requires libgrib_api.so.0()(64bit))

The issue is obsoletes.

python-django < 1.11.13-2.el7 Django < 1.5.5-3 python-django < 1.5.5-3

If both should coexist, then there is a packaging issue in python-django16. It should create python2-django16 sub-package and not pyton2-django like it does now.

The issue I commented on, causes python-tilestache-1.49.11-3.el7.noarch dependencies to be broken.

There is a packaging issue in python2-modestmaps-1.4.7-1.el7.

%if 0%{?fedora} %{?python_provide:%python_provide python2-modestmaps} %endif

This causes python_provide to miss on epel7 causing python-modestmaps provide to be missing.

This update breaks dependencies of RviewBoard-2.6.17-1.el7 (Requires python2-django(abi) = 0:1.6) and python-djblets-0.9.9-2.el7 (in epel testing, because it requires explicitily python-django16). I'd guess there need to be cordinated update of these packages.

I guess you ment to write:

Use python%%{python3_pkgversion}- packages (python34- no longer works)

Changelog entry looks really wrong.

User Icon tis commented & provided feedback on pdns-4.0.6-2.el7 3 years ago
karma

Older version of pdns provides sub-packages backend-geo and backend-lmdb. These sub-packages were removed in this update but because they were not obsoleted, update will fail on systems with those installed. Suggested fix:

Obsoletes: pdns-backend-geo < 4.0.6-1 Obsoletes: pdns-backend-lmdb < 4.0.6-1

karma

python2-nitrate is not installable because it depends on python-gssapi which is not available.

Actually not that straight forward. Only python3-sphinx-doc and python3-sphinx-latex dependencies should be changed to use python3_pkgversion for dependencies.

karma

Some dep issues, easy to fix, check that all instances of python3 are replaced with python%{python3_pkgversion}, now there are dep issues and sub-packages with wrong naming.

karma

snapd-selinux is not installable because of dependency policycoreutils-python-utils. On rhel that is policycoreutils-python.

There is a packaging issue in deps:

package: 1:julietaula-montserrat-alternates-fonts-7.200-4.el7.noarch

unresolved deps:

 julietaula-montserrat-fonts-common = 0:7.200-4.el7

Note: Main package has epoch 1 but dependency is missing that.

python2-ModulemdTranslationHelpers depends on python2dist(pygobject) but nothing provides that so package is not installable.

karma

Package python2-libpamtest is missing use of python_provide macro. This causes following issues:

Following provide and Obsoletes are missing:

Provides: python-libpamtest = %{version}-%{release}
Obsoletes: python-libpamtest < %{version}-%{release}

These are needed to provide sufficent upgrade path.

User Icon tis commented & provided feedback on pagure-5.0.1-2.el7 3 years ago
karma

I found same dependency issue.