Users upgrading from dnf-1.1.2-2 are advised to perform "dnf upgrade dnf* --allowerasing" before actual upgrade.

dnf-1.1.2-4.fc22

  • don't import readline as it causes crashes in Anaconda (related:RhBug:1258364)

hawkey-0.6.1-2.fc22

  • fixed memleaks from 2f5b9af (Jan Silhan)
  • Support list of strings in provides/requires. (RhBug:1243005)(RhBug:1243002) (Valentina Mukhamedzhanova)
  • Add globbing support to dependency queries. (RhBug:Related:1259650)(RhBug:Related:1249073) (Valentina Mukhamedzhanova)
  • package: filter out solvable:prereqmarker (RhBug:1186721) (Michal Luscon)
  • skip already filtered items (Michael Mraka)

dnf-plugins-core-0.1.12-3.fc22

  • revert python2-dnf requirements

How to install

sudo dnf upgrade --advisory=FEDORA-2015-3528c659e4

This update has been submitted for testing by mluscon.

4 years ago

This update has been pushed to testing.

4 years ago
User Icon dandim commented & provided feedback 4 years ago
karma

Works good

User Icon kevin commented & provided feedback 4 years ago
karma

works fine here

User Icon dhgutteridge commented & provided feedback 4 years ago
karma

No issues noted.

BZ#1234491 [UX] dnf list installed: show repo id the package was installed from
Test Case base update cli
User Icon hreindl commented & provided feedback 4 years ago
karma

works for me

This update has been submitted for stable by bodhi.

4 years ago
User Icon ppisar commented & provided feedback 4 years ago
karma

This one is possible to install.

This update has been pushed to stable.

4 years ago

Please login to add feedback.

Metadata
Type
enhancement
Karma
5
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
5
Stable by Time
disabled
Dates
submitted
4 years ago
in testing
4 years ago
in stable
4 years ago
BZ#1048433 RFE --downloadonly
0
0
BZ#1186721 hawkey.Package.requires contains 'solvable:prereqmarker'
0
0
BZ#1234491 [UX] dnf list installed: show repo id the package was installed from
0
1
BZ#1243002 Query.filter(requires=XXX) fails for lists (or even segfaults)
0
0
BZ#1243005 Query.filter(provides=XXX) fails for lists
0
0
BZ#1249073 dnf repoquery does not support wildcards in --whatrequires
0
0
BZ#1250038 [abrt] python-dnf: completion_helper.py:84:run:IndexError: list index out of range
0
0
BZ#1254687 DNF does not display any translations
0
0
BZ#1254982 dnf-automatic generates emails with broken charset
0
0
BZ#1256531 dnf install crashes if terminal window is too small
0
0
BZ#1258364 Some important dnf output goes to STDERR and not to STDOUT
0
0
BZ#1259650 "dnf provides" or "dnf repoquery --whatprovides" does not support globs
0
0
BZ#1259657 No dnf-command() provides for dnf commands
0
0
BZ#1260198 python-dnf should provide python2-dnf
0
0
BZ#1261656 DNF group update doesn't work
0
0
BZ#1261766 RFE: way to force no metadata expiration system-wide
0
0
BZ#1262082 'ascii' codec can't decode byte 0xc3 in position 40: ordinal not in range(128)
0
0

Automated Test Results

Test Cases

0 1 Test Case base update cli
0 0 Test Case desktop update graphical/it
0 0 Test Case desktop update notification/it
0 0 Test Case langpacks packages