FEDORA-2015-38e69423f3

enhancement update in Fedora 23 for dnf, dnf-plugins-core, & 1 more

Status: stable 3 years ago

dnf-1.1.2-4.fc23

  • don't import readline as it causes crashes in Anaconda (related:RhBug:1258364)

hawkey-0.6.1-2.fc23

  • fixed memleaks from 2f5b9af (Jan Silhan)
  • Support list of strings in provides/requires. (RhBug:1243005)(RhBug:1243002) (Valentina Mukhamedzhanova)
  • Add globbing support to dependency queries. (RhBug:Related:1259650)(RhBug:Related:1249073) (Valentina Mukhamedzhanova)
  • package: filter out solvable:prereqmarker (RhBug:1186721) (Michal Luscon)
  • skip already filtered items (Michael Mraka)

dnf-plugins-core-0.1.12-3.fc23

  • bump version to preserve upgrade path

How to install

sudo dnf upgrade --advisory=FEDORA-2015-38e69423f3

Comments 10

This update has been submitted for testing by mluscon.

This update has been pushed to testing.

This one works fine so far.

karma: +1 #1254687: +1 base update cli: +1

Works fine so far.

karma: +1

This update has been submitted for stable by bodhi.

nothing broke so far

karma: +1

This update has been pushed to stable.

Works, and fixes https://bugzilla.redhat.com/show_bug.cgi?id=1262082 for me. But the update command was 'LANG=C sudo dnf --enablerepo=updates-testing update hawkey dnf-plugins-core dnf', because in spanish if you don't set LANG=C the previous dnf didn't work, after the upgrade you can use dnf in spanish again.

Content Type
RPM
Status
stable
Test Gating
Submitted by
Update Type
enhancement
Update Severity
unspecified
Karma
+5
stable threshold: 5
unstable threshold: -3
Autopush
Enabled
Dates
submitted 3 years ago
in testing 3 years ago
in stable 3 years ago

Related Bugs 17

00 #1048433 RFE --downloadonly
00 #1186721 hawkey.Package.requires contains 'solvable:prereqmarker'
00 #1234491 [UX] dnf list installed: show repo id the package was installed from
00 #1243002 Query.filter(requires=XXX) fails for lists (or even segfaults)
00 #1243005 Query.filter(provides=XXX) fails for lists
00 #1249073 dnf repoquery does not support wildcards in --whatrequires
00 #1250038 [abrt] python-dnf: completion_helper.py:84:run:IndexError: list index out of range
0+1 #1254687 DNF does not display any translations
00 #1254982 dnf-automatic generates emails with broken charset
00 #1256531 dnf install crashes if terminal window is too small
00 #1258364 Some important dnf output goes to STDERR and not to STDOUT
00 #1259650 "dnf provides" or "dnf repoquery --whatprovides" does not support globs
00 #1259657 No dnf-command() provides for dnf commands
00 #1260198 python-dnf should provide python2-dnf
00 #1261656 DNF group update doesn't work
00 #1261766 RFE: way to force no metadata expiration system-wide
00 #1262082 'ascii' codec can't decode byte 0xc3 in position 40: ordinal not in range(128)

Automated Test Results

Test Cases

0+2 Test Case base update cli
00 Test Case desktop update graphical/it
00 Test Case desktop update notification/it
00 Test Case langpacks packages