Qt 5.5.1 bugfix release, see also https://blog.qt.io/blog/2015/10/15/qt-5-5-1-released/


fcitx-qt5-1.0.4-3.fc22

  • rebuild(qt5), tighten qt5 dep, .spec cosmetics

Logout Required
After installing this update it is required that you logout of your current user session and log back in to ensure the changes supplied by this update are applied properly.

How to install

sudo dnf upgrade --advisory=FEDORA-2015-3c671e20a3

This update has been submitted for testing by rdieter.

4 years ago

rdieter edited this update.

4 years ago

This update has been pushed to testing.

4 years ago
User Icon yuwata commented & provided feedback 4 years ago
karma

works for me

Works with KDE.

karma: +1

User Icon dhgutteridge commented & provided feedback 4 years ago
karma

No issues noted in everyday use of KDE Plasma.

rdieter edited this update.

New build(s):

  • qscintilla-2.8.4-6.fc22
4 years ago

This update has been submitted for testing by rdieter.

4 years ago

This update has been pushed to testing.

4 years ago

Please help adding fcitx-qt5-1.0.4-3.fc22 to this update.

rdieter edited this update.

New build(s):

  • fcitx-qt5-1.0.4-3.fc22
4 years ago

This update has been submitted for testing by rdieter.

4 years ago

This update has been pushed to testing.

4 years ago

rdieter edited this update.

New build(s):

  • qt5-qtbase-5.5.1-8.fc22

Removed build(s):

  • qt5-qtbase-5.5.1-4.fc22
4 years ago

This update has been submitted for testing by rdieter.

4 years ago

This update has been pushed to testing.

4 years ago
User Icon filiperosset commented & provided feedback 4 years ago
karma

no regressions noted

User Icon jwakely commented & provided feedback 4 years ago
karma

This update is essential because there are already packages in stable that depend on symbols in the new qt5-qtbase, see https://bugzilla.redhat.com/show_bug.cgi?id=1282261

rdieter edited this update.

4 years ago

rdieter edited this update.

4 years ago

rdieter edited this update.

4 years ago

This update has been submitted for stable by bodhi.

4 years ago
User Icon germano provided feedback 4 years ago
karma
BZ#1282261 5.4.3-1 update fails to load with missing symbol, causes kded5 to fail
User Icon fredyn commented & provided feedback 4 years ago
karma

This update is essential for Plasma 5.4.3 (in stable), resolving several stability issues. Missing symbol issue is now gone, kded & powerdevil run fine (restored Suspend & Clipboard functionality for me), and kscreen no longer "forgets" the Display Configuration at logout.

I updated all qt5 packages listed above. Note that some of these were missing on my F22 (which was upgraded earlier from F20), so I also installed python-qt5 and its dependencies qt5-qtdoc qt5-qtwayland qt5-qtimageformats qt5-qtquick1 qt5-qttranslations at this point.

Plasma 5.4.3 is now much more stable, external monitor with nouveau is working as well. This is with kernel 4.1.3-201.fc22.x86_64 -- I'll retest with kernel 4.2.5 later.

BZ#1282261 5.4.3-1 update fails to load with missing symbol, causes kded5 to fail
User Icon sudhirkhanger commented & provided feedback 4 years ago
karma

This update fixes all the Plasma related problem we have faced recently. Seems to work so far. Please push it to stable.

BZ#1282261 5.4.3-1 update fails to load with missing symbol, causes kded5 to fail

This update has been pushed to stable.

4 years ago
User Icon gjanssens commented & provided feedback 4 years ago
karma

I get a packaging conflict with an already installed python3-qt5 when running dnf --enablerepo=updates-testing update qt5*

Error: Transaction check error: file /usr/lib/rpm/macros.d/macros.pyqt5 from install of python-qt5-5.5.1-2.fc22.x86_64 conflicts with file from package python3-qt5-5.5-1.fc22.x86_64

User Icon gjanssens commented & provided feedback 4 years ago
karma

I get a packaging conflict with an already installed python3-qt5 when running dnf --enablerepo=updates-testing update qt5*

Error: Transaction check error: file /usr/lib/rpm/macros.d/macros.pyqt5 from install of python-qt5-5.5.1-2.fc22.x86_64 conflicts with file from package python3-qt5-5.5-1.fc22.x86_64

User Icon gjanssens commented & provided feedback 4 years ago
karma

I get a packaging conflict with an already installed python3-qt5 when running dnf --enablerepo=updates-testing update qt5*

Error: Transaction check error: file /usr/lib/rpm/macros.d/macros.pyqt5 from install of python-qt5-5.5.1-2.fc22.x86_64 conflicts with file from package python3-qt5-5.5-1.fc22.x86_64

User Icon gjanssens commented & provided feedback 4 years ago

Oops, I never meant this comment to appear 3 times. Sorry about that. Meanwhile I had opened a bug report which got closed as not a bug that explained I also had to upgrade python-qt5 and python3-qt5 together with qt5*.

Sorry about all the noise.


Please login to add feedback.

BZ#1282261 5.4.3-1 update fails to load with missing symbol, causes kded5 to fail
0
3

Automated Test Results