FEDORA-2015-48f718ed1b

enhancement update in Fedora 22 for vim

Status: obsolete

This update is mostly to check if some major changes in the way how the Fedora vim rpms are created broke something. Previous vim packages had only fixes for the vim binaries, but almost never for vim runtime files (vim scripts). We now create a tarball directly from upstream git which includes all runtime fixes and build vim from that tarball.

vim-7.4.909-1.fc21

  • patchlevel 909
  • Fedora vim now uses tarballs created from upstream git instead of just upstream patches. Now runtime files will have fixes, too.

vim-7.4.909-1.fc22

  • patchlevel 909
  • Fedora vim now uses tarballs created from upstream git instead of just upstream patches. Now runtime files will have fixes, too.

Comments 11

This update has been submitted for testing by karsten.

This update has been pushed to testing.

Works for me

karma: +1

After update vim ignores tabstop, shiftwidth and softtabstop from .vimrc

critpath: +1

works for me

karma: +1

Breaks upgrade path (F22 -> F23, which also breaks perl dependency when upgrading F22 -> F23). Please submit F23 updatest request first.

no regressions noted

karma: +1

works for me

karma: +1

This update has reached 14 days in testing and can be pushed to stable now if the maintainer wishes

works for me, no regressions noted.

karma: +1

This update has been obsoleted by vim-7.4.1718-1.fc22.

Add Comment & Feedback

Please login to add feedback.

Content Type
RPM
Status
obsolete
Test Gating
Submitted by
Update Type
enhancement
Update Severity
unspecified
Karma
+5
stable threshold: 3
unstable threshold: -3
Autopush (karma)
Disabled
Autopush (time)
Disabled
Dates
submitted 3 years ago
in testing 3 years ago

Automated Test Results