stable
FEDORA-2015-b273e4a581 created by mcrha 6 years ago for Fedora 23

Rebuild against newer samba and finally drop the dependency on libsamba-debug-samba4 private samba library.

How to install

sudo dnf upgrade --refresh --advisory=FEDORA-2015-b273e4a581

This update has been submitted for testing by mcrha.

6 years ago

This update has been pushed to testing.

6 years ago

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

6 years ago
User Icon anonymous commented & provided feedback 6 years ago

The samba dependency is solved, but now evolution crashes when adding a MAPI account (at the point of authentication)

karma: -1

BZ#1277023 openchange-2.3-5.fc23.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.3.0RC4)(64bit)

mcrha edited this update.

New build(s):

  • openchange-2.3-8.fc23

Removed build(s):

  • openchange-2.3-7.fc23
6 years ago

This update has been submitted for testing by mcrha.

6 years ago
User Icon mcrha commented & provided feedback 6 years ago

The crash you mention, could you file a bug for it, please? It'll be better for investigation what precisely broke. As far as I tried, openchange update didn't break evolution-mapi for me,

The 2.3-7 was a simple rebuild, while the 2.3-8 drops the dependency on the samba's private libsamba-debug-samba4 library, thus any future updates of samba will not break openchange on this library.

This update has been pushed to testing.

6 years ago
User Icon tuksgig commented & provided feedback 6 years ago

https://retrace.fedoraproject.org/faf/reports/455195/ and https://bugzilla.redhat.com/show_bug.cgi?id=1273934. After the latest update the crash tool won't allow me to file a bug because "the process had locked memory which usually indicates efforts to protect sensitive data (passwords)"

User Icon tuksgig commented & provided feedback 6 years ago

After the update, here is the new abort trace: https://retrace.fedoraproject.org/faf/reports/924758/

User Icon mcrha commented & provided feedback 6 years ago

Thanks. The initial FAF report shows a crash after you presses an "Authenticate" button of a MAPI account wizard, in some gtk3 CSS related code. One pretty close upstream bug report is https://bugzilla.gnome.org/show_bug.cgi?id=747422 which suggest an issue on the client side, at least in case of the epiphany. Evolution(-data-server) has an issue with memory filled as https://bugzilla.gnome.org/show_bug.cgi?id=757789 . That one is fixed in evolution-data-server 3.18.2-2 and 3.18.3. I do not know whether it is related to what you get or not. I tried to reproduce this with an up-to-date Fedora 23 running GNOME with this openchange (from updates-testing) and it passes the Authenticate part without any issue.

User Icon daveo commented & provided feedback 6 years ago
karma

I don't have a crash

BZ#1277023 openchange-2.3-5.fc23.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.3.0RC4)(64bit)

This update has been submitted for stable by mcrha.

6 years ago

This update has been pushed to stable.

6 years ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
medium
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
6 years ago
in testing
6 years ago
in stable
6 years ago
modified
6 years ago
BZ#1277023 openchange-2.3-5.fc23.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.3.0RC4)(64bit)
0
1

Automated Test Results