FEDORA-2016-0641937c67 created by pbrobinson 3 years ago for Fedora 24
stable

Don't pull in the python2 stack due to selinux changes

How to install

sudo dnf upgrade --advisory=FEDORA-2016-0641937c67

This update has been submitted for testing by pbrobinson.

3 years ago

This update has been pushed to testing.

3 years ago
User Icon yuwata commented & provided feedback 3 years ago
karma

works for me

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

3 years ago

This update has been submitted for stable by pbrobinson.

3 years ago

This update has been pushed to stable.

3 years ago
User Icon anonymous commented & provided feedback 3 years ago

Does it matter that this package depends on selinux-policy-3.13.1-191.23 which is not yet in stable?

User Icon anonymous commented & provided feedback 3 years ago

Yes, it matters (see dnf output, and more issues outlined in bug linked at bottom) ...

# dnf update
Dependencies resolved.
================================================================================
 Package                   Arch        Version               Repository    Size
================================================================================
Skipping packages with broken dependencies:
 firewall-config           noarch      0.4.4.2-2.fc24        updates      153 k
 firewalld                 noarch      0.4.4.2-2.fc24        updates      454 k
 firewalld-filesystem      noarch      0.4.4.2-2.fc24        updates       68 k
 python3-firewall          noarch      0.4.4.2-2.fc24        updates      351 k

Transaction Summary
================================================================================
Skip  4 Packages

Nothing to do.
Complete!
# dnf update --best
Error: package firewalld-0.4.4.2-2.fc24.noarch conflicts with selinux-policy < 3.13.1-191.23 provided by selinux-policy-3.13.1-191.21.fc24.noarch.
package selinux-policy-targeted-3.13.1-191.21.fc24.noarch requires selinux-policy = 3.13.1-191.21.fc24, but none of the providers can be installed.
package firewall-config-0.4.4.2-2.fc24.noarch requires firewalld = 0.4.4.2-2.fc24, but none of the providers can be installed.
package firewalld-0.4.4.2-1.fc24.noarch requires firewalld-filesystem = 0.4.4.2-1.fc24, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

I've reported this issue as a bug against bodhi: https://github.com/fedora-infra/bodhi/issues/1212


Please login to add feedback.

Metadata
Type
enhancement
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Dates
submitted
3 years ago
in testing
3 years ago
in stable
3 years ago
BZ#1401378 firewalld 0.4.4.2 incorrectly pulls in python2 dependencies due to selinux sub package
0
0

Automated Test Results