Update to upstream version 3.2.2 which fixes serialization vulnerability

How to install

sudo dnf upgrade --advisory=FEDORA-2016-0c5838abc5

This update has been submitted for testing by msimacek.

5 years ago

This update has been pushed to testing.

5 years ago
User Icon akurtakov commented & provided feedback 5 years ago
karma

works for me

User Icon srakitnican commented & provided feedback 5 years ago
karma

There is probably a bug in a package somewhere:

$ rpm -q apache-commons-collections-javadoc apache-commons-collections
apache-commons-collections-javadoc-3.2.1-26.fc23.noarch
apache-commons-collections-3.2.1-26.fc23.noarch

While

$ sudo dnf upgrade --enablerepo=updates-testing apache-commons-collections apache-commons-collections-javadoc

Returns

Error: Transaction check error:
  file /usr/share/javadoc/apache-commons-collections from install of apache-commons-collections-javadoc-3.2.2-1.fc23.noarch conflicts with file from package apache-commons-collections-javadoc-3.2.1-26.fc23.noarch

As found by another forum user and me.

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

5 years ago

msimacek edited this update.

New build(s):

  • apache-commons-collections-3.2.2-3.fc23

Removed build(s):

  • apache-commons-collections-3.2.2-1.fc23
5 years ago

This update has been submitted for testing by msimacek.

5 years ago

This update has been pushed to testing.

5 years ago

This update has been submitted for stable by msimacek.

5 years ago

This update has been pushed to stable.

5 years ago

Please login to add feedback.

Metadata
Type
security
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
5 years ago
in testing
5 years ago
in stable
5 years ago
modified
5 years ago
BZ#1316430 Version 3.2.1 has a CVSS 10.0 vulnerability
0
0

Automated Test Results