FEDORA-2016-2417b6677a created by dkaspar 3 years ago for Fedora 24
stable

tl;dr; version: TCSH has been updated to latest upstream version.

Highlights

  • tcsh can now be build with gcc-6
  • $vimode variable can now be used to control VImode, see 'man tcsh'
  • additional relevant patches backported from upstream
  • many fixes that should improve user experience with tcsh

Other

  • code not accepted/supported by upstream has been removed
  • specfile has gone through significant maintenance
  • $tcsh_posix_status variable is now deprecated, use $anyerror instead

How to install

sudo dnf upgrade --advisory=FEDORA-2016-2417b6677a

This update has been submitted for testing by dkaspar.

3 years ago
User Icon anonymous commented & provided feedback 3 years ago

karma: +1

BZ#1303323 tcsh: interposed malloc is not ABI-compliant due to lack of alignment
User Icon frieben commented & provided feedback 3 years ago
karma

Tcsh works again as expected, thanks!

BZ#1303323 tcsh: interposed malloc is not ABI-compliant due to lack of alignment

dkaspar edited this update.

3 years ago

dkaspar edited this update.

3 years ago
User Icon dkaspar commented & provided feedback 3 years ago

I would prefer to keep this in 'testing' as long as possible, because of the significant number of changes made to tcsh.

IMHO, there shouldn't be a significant problem, but just to be sure.

If there will be no problems/negative karma, I guess I will push it to stable on May 30th, 2016.

This update has been pushed to testing.

3 years ago
User Icon anonymous commented & provided feedback 3 years ago

@dkaspar - as this is a fairly critical crash for those of us who do not use bash for our default shell, holding this seems unnecessary.

I've loaded this on my fc24 test host and it addresses the crash seen by using command and file completion.

BZ#1303323 tcsh: interposed malloc is not ABI-compliant due to lack of alignment
User Icon goeran commented & provided feedback 3 years ago
karma

Fixes #1303323, and seems to work just fine in general.

BZ#1303323 tcsh: interposed malloc is not ABI-compliant due to lack of alignment
User Icon dkaspar commented & provided feedback 3 years ago

@anonymous OK, I will discuss this with my peers again, to find the best course of action.

User Icon dkaspar commented & provided feedback 3 years ago

My peers think I should keep this in testing for a little bit longer. I'm having PTO on Friday & Monday, so we will see how the karma will look on next Tuesday.

User Icon goeran commented & provided feedback 3 years ago

For the record, I believe #1333523 was introduced in this version. Personally, I wouldn't let that stop the update; the problem it fixes is much more serious. But just to let anyone listening know.

This update has reached 3 days in testing and can be pushed to stable now if the maintainer wishes

3 years ago
User Icon dkaspar commented & provided feedback 3 years ago

@goeran Thank you for the bug submission.

Since the beta of F24 has been released today, and previous package of tcsh is non-functional, I will push this to stable so people testing F24-beta can at least use the tcsh.

I will hope no more problems/regression will occur, and I will try to fix this ASAP.

This update has been submitted for stable by dkaspar.

3 years ago

This update has been pushed to stable.

3 years ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
high
Karma
2
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
10
Dates
submitted
3 years ago
in testing
3 years ago
in stable
3 years ago
modified
3 years ago
BZ#1303323 tcsh: interposed malloc is not ABI-compliant due to lack of alignment
0
2
BZ#1327075 tcsh: Depends on type union wait
0
0

Automated Test Results