FEDORA-2016-3cac5e839d created by toshio 6 years ago for Fedora 22
obsolete

Ansible v2 upstream rewrite with many bugfixes and new features. See upstream changelog for details: https://github.com/ansible/ansible/blob/devel/CHANGELOG.md

This update has been submitted for testing by toshio.

6 years ago
User Icon fale provided feedback 6 years ago
karma

This update has been pushed to testing.

6 years ago
User Icon mavit commented & provided feedback 6 years ago
karma

This is an enhancement update, not a bugfix update. Because playbooks need porting to remain functional, I believe that this update does not belong in Fedora 22 or 23, as per the Fedora updates policy.

User Icon jcline commented & provided feedback 6 years ago
karma

Although I'm definitely excited for Ansible 2.0, I agree with mavit. This is not a backwards-compatible update and is not in line with the update policy.

User Icon rbarlow commented & provided feedback 6 years ago
karma

I agree with some of the other downvoters. Ansible 2.0 is great and I thank you for maintaining the package, but please only put 2.0 in Rawhide so that users don't have to port their playbooks except on a major OS upgrade as per the packaging guidelines.

I just tested my ansible 1.9 playbooks on 2.0 and 2.0 is not backwards-compatible.

karma: -1

Hi,

My company uses F23 for workstations and relies on ansible for mission critical deployments and other work.

An incompatible update from a simple dnf upgrade would have a negative impact and cause instability in our environment and workload. Thank you.

karma: -1

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

6 years ago

Ansible 2.0 is (with a few rare exceptions where it rejects something that 1.9.x permitted, but was incorrect) compatible playbook wise with 1.9.x.

Could everyone here who has hit a playbook that doesn't work with 2.0, but does work with 1.9 file a ticket upstream or a bug report in bugzilla. We want upstream ansible to fix these cases and release 2.0.x with those fixes before we push to stable.

This update has been obsoleted by ansible-2.0.1.0-2.fc22.

5 years ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
-2
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
disabled
Stable by Time
disabled
Dates
submitted
6 years ago
in testing
6 years ago

Automated Test Results