php-nikic-php-parser: this is a PHP 5.2 to PHP 7.0 parser written in PHP. Its purpose is to simplify static code analysis and manipulation.

This package provides the library version 2 and the php-parse command. The php-PHPParser package provides the library version 1

Documentation: https://github.com/nikic/PHP-Parser/tree/master/doc

Autoloader: /usr/share/php/PhpParser2/autoload.php


php-PHPParser: drop the php-parse-command


php-jeremeamia-superclosure: allow to use php-parser v1 or v2

How to install

sudo dnf install --advisory=FEDORA-2016-6a65157098 \*

This update has been submitted for testing by remi.

4 years ago

remi edited this update.

New build(s):

  • php-nikic-php-parser-2.1.0-4.fc24
  • php-PHPParser-1.4.1-4.fc24

Removed build(s):

  • php-nikic-php-parser-2.1.0-3.fc24
4 years ago

This update has been pushed to testing.

4 years ago

remi edited this update.

New build(s):

  • php-jeremeamia-superclosure-2.2.0-3.fc24
4 years ago

This update has been submitted for testing by remi.

4 years ago

remi edited this update.

4 years ago

This update has been pushed to testing.

4 years ago

This update has reached 3 days in testing and can be pushed to stable now if the maintainer wishes

4 years ago

This update has been submitted for stable by remi.

4 years ago

This update has been pushed to stable.

4 years ago

Please login to add feedback.

Metadata
Type
newpackage
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
4 years ago
in testing
4 years ago
in stable
4 years ago
modified
4 years ago
BZ#1327566 Review Request: php-nikic-php-parser - A PHP parser written in PHP
0
0

Automated Test Results