Update to the latest upstream version, with rebuilt spatialite-tools.

How to install

sudo dnf upgrade --advisory=FEDORA-2016-990c070b19

This update has been submitted for testing by jstanek.

3 years ago

This update has been pushed to testing.

3 years ago
User Icon yuwata commented & provided feedback 3 years ago
karma

works for me

User Icon anonymous commented & provided feedback 3 years ago

06:20:21 : YUM: --> Running transaction check 06:20:21 : YUM: ---> Package sqlite.x86_64 0:3.10.2-1.fc23 will be updated 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 1:epiphany-3.18.3-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: subversion-gnome-1.9.3-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: PackageKit-glib-1.0.11-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: telepathy-gabble-0.18.2-5.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 1:epiphany-runtime-3.18.3-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: icecat-38.6.0-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: gnome-calendar-3.18.2.1-2.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: subversion-kde-1.9.3-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 1:folks-0.11.1-3.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: qt5-qtbase-5.5.1-11.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: darktable-1.6.9-6.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: libgpod-0.8.3-10.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: shotwell-0.23.0-0.1.20160105gitf2fb1f7.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: midori-0.5.11-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: evolution-data-server-3.18.5-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: setools-libs-3.3.8-8.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: libsoup-2.52.2-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: gom-0.3.1-2.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: subversion-1.9.3-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: xmoto-0.5.11-8.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: qt5-qtwebkit-5.5.1-4.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: PackageKit-1.0.11-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: redland-1.0.17-4.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: python-libs-2.7.10-8.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: thunderbird-38.5.0-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: evolution-3.18.5-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: gnome-shell-3.18.3-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: grilo-plugins-0.2.17-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: tracker-1.6.1-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: sqlite-devel-3.11.0-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: yum-metadata-parser-1.1.4-15.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: python3-libs-3.4.3-5.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: subversion-tools-1.9.3-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: systemtap-devel-2.9-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: createrepo_c-0.10.0-2.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: ekiga-4.0.1-23.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: font-manager-0.7.2-3.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 1:liferea-1.10.18-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: avidemux-libs-2.6.10-3.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: telepathy-logger-0.8.2-2.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: webkitgtk-2.4.9-3.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: colord-1.2.12-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: telepathy-salut-0.8.1-8.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 1:nfs-utils-1.3.3-6.rc3.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 1:qt-4.8.7-5.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: zeitgeist-libs-0.9.16-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: nss-softokn-3.22.0-1.0.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 2:yelp-3.17.2-3.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: xulrunner-44.0-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: createrepo_c-libs-0.10.0-2.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: webkitgtk4-devel-2.10.7-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: akonadi-1.13.0-20.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: subversion-libs-1.9.3-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: webkitgtk3-2.4.9-3.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: xmms2-0.8-29.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: python-apsw-3.8.4.3.r1-5.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: qtwebkit-2.3.4-8.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: fbreader-0.12.10-18.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 2:yelp-libs-3.17.2-3.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: librawstudio-2.1-0.9.20150511git75ef4c4_rawspeed_4ea46dd.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: webkitgtk4-2.10.7-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: firefox-44.0.2-3.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: rygel-0.28.2-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: libchamplain-0.12.11-1.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: libaccounts-glib-1.18-2.fc23.x86_64 06:20:21 : YUM: --> Processing Dependency: libsqlite3.so.0()(64bit) for package: rawstudio-2.1-0.9.20150511git75ef4c4_rawspeed_4ea46dd.fc23.x86_64 06:20:21 : YUM: ---> Package sqlite.x86_64 0:3.11.0-1.fc23 will be an update 06:20:21 : YUM: ---> Package sqlite-devel.x86_64 0:3.10.2-1.fc23 will be updated 06:20:21 : YUM: ---> Package sqlite-devel.x86_64 0:3.11.0-1.fc23 will be an update 06:20:21 : YUM: --> Running transaction check 06:20:21 : YUM: ---> Package sqlite-libs.x86_64 0:3.11.0-1.fc23 will be installed 06:20:21 : YUM: --> Finished Dependency Resolution 06:20:26 : ERROR: Dependency resolving completed with errors 06:20:26 : ERROR: Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Protected multilib versions: sqlite-3.11.0-1.fc23.x86_64 != sqlite-3.10.2-1.fc23.i686

karma: -1

BZ#1288606 Split library from binary to drop unnecessary dependencies.
User Icon hreindl commented & provided feedback 3 years ago
karma

works for me - @anonymous: you need to update ALL packages in the same transaction and sqlite-3.11.0-1.fc23.x86_64 != sqlite-3.10.2-1.fc23.i686 is pretty clear, multilib is all or nothing

User Icon anonymous commented & provided feedback 3 years ago

@hreindl In a similar fashion you can install sqlite-3.10.2-1.fc23.i686 and try to dnf upgrade :)

This update has been submitted for stable by bodhi.

3 years ago
User Icon dhgutteridge commented & provided feedback 3 years ago
karma

No issues noted.

User Icon anonymous commented & provided feedback 3 years ago

Congrats! Now this update has been submitted for stable not just for YOU & we can now easily calculate the Fourier coefficients ))

User Icon hreindl commented & provided feedback 3 years ago

@anonymous - this is NOT a chatroom - the whole purpose of bodhi and karma IS to test proposed updates and help them to get to stable (the exactl ybuild you commetn and give karma and not builds for other Fedora versions or whatever) and when you download packages from koji you are supposed to understand dependecnies and how to get them running - otherwise wait until they are pushed to updates-testing and use "fedora-easy-karma" which only asks you about packages running on your system to push feedback in bodhi (way too much people comment for the wrong Fedora version and so a unrelated build)

User Icon anonymous commented & provided feedback 3 years ago

As you know, they've already pushed to updates-testing repository and I'm waiting hard for dnf not to skip them with broken dependencies ;)

User Icon anonymous commented & provided feedback 3 years ago

Just a little tip or HOWTO ;) FEDORA-2016-3fddf981c5

User Icon anonymous commented & provided feedback 3 years ago

& where are results of Automated Test??

User Icon xosevp commented & provided feedback 3 years ago
karma

BROKEN !!!

--cut--

yum-deprecated -y update --skip-broken

[...] Resolving Dependencies --> Running transaction check ---> Package sqlite.x86_64 0:3.10.2-1.fc23 will be updated --> Processing Dependency: libsqlite3.so.0()(64bit) for package: PackageKit-glib-1.0.11-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: telepathy-gabble-0.18.2-5.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 1:epiphany-runtime-3.18.3-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: subversion-perl-1.9.3-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: grilo-plugins-0.2.17-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 1:folks-0.11.1-3.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: ibus-libpinyin-1.7.4-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: qt5-qtbase-5.5.1-11.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: libgpod-0.8.3-10.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: shotwell-0.23.0-0.1.20160105gitf2fb1f7.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: evolution-data-server-3.18.5-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: libsoup-2.52.2-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: gom-0.3.1-2.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: subversion-1.9.3-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: libchamplain-0.12.11-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: qt5-qtwebkit-5.5.1-4.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 1:nfs-utils-1.3.3-6.rc3.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: gnome-contacts-3.18.1-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: python-libs-2.7.10-8.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: tracker-1.6.1-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: evolution-3.18.5-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: gnome-shell-3.18.3-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: sqlite-devel-3.11.0-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: redland-1.0.17-4.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: thunderbird-38.6.0-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: aircrack-ng-1.2-0.8rc2.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: python3-libs-3.4.3-5.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: webkitgtk3-2.4.9-3.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: createrepo_c-0.10.0-2.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: systemtap-client-2.9-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: telepathy-logger-0.8.2-2.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: evolution-ews-3.18.5-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: firefox-44.0.2-3.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: webkitgtk-2.4.9-3.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: colord-1.2.12-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: telepathy-salut-0.8.1-8.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 1:qt-4.8.7-5.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: bijiben-3.18.2-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: nss-softokn-3.22.0-1.0.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 2:yelp-3.17.2-3.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: libchewing-0.4.0-5.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: createrepo_c-libs-0.10.0-2.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: python-apsw-3.8.4.3.r1-5.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: akonadi-1.13.0-20.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: subversion-libs-1.9.3-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: zeitgeist-libs-0.9.16-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: setools-libs-3.3.8-8.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: qtwebkit-2.3.4-8.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: 2:yelp-libs-3.17.2-3.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: perl-DBD-SQLite-1.48-3.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: PackageKit-gstreamer-plugin-1.0.11-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: webkitgtk4-2.10.7-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: simple-scan-3.18.2-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: yum-metadata-parser-1.1.4-15.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: rygel-0.28.2-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: hugin-2015.0.0-1.fc23.x86_64 --> Processing Dependency: libsqlite3.so.0()(64bit) for package: hugin-base-2015.0.0-1.fc23.x86_64 ---> Package sqlite.x86_64 0:3.11.0-1.fc23 will be an update ---> Package sqlite-devel.i686 0:3.10.2-1.fc23 will be updated ---> Package sqlite-devel.x86_64 0:3.10.2-1.fc23 will be updated ---> Package sqlite-devel.i686 0:3.11.0-1.fc23 will be an update ---> Package sqlite-devel.x86_64 0:3.11.0-1.fc23 will be an update --> Running transaction check ---> Package sqlite-libs.x86_64 0:3.11.0-1.fc23 will be installed --> Finished Dependency Resolution Error: Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.:

     1. You have an upgrade for sqlite which is missing some
        dependency that another package requires. Yum is trying to
        solve this by installing an older version of sqlite of the
        different architecture. If you exclude the bad architecture
        yum will tell you what the root cause is (which package
        requires what). You can try redoing the upgrade with
        --exclude sqlite.otherarch ... this should give you an error
        message showing the root cause of the problem.

     2. You have multiple architectures of sqlite installed, but
        yum can only see an upgrade for one of those architectures.
        If you don't want/need both architectures anymore then you
        can remove the one with the missing update and everything
        will work.

     3. You have duplicate versions of sqlite installed already.
        You can use "yum check" to get yum show these errors.

   ...you can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).

   Protected multilib versions: sqlite-3.11.0-1.fc23.x86_64 != sqlite-3.10.2-1.fc23.i686

Yum-utils package has been deprecated, use dnf instead. See 'man yum2dnf' for more information.

Loaded plugins: fastestmirror, priorities No old kernels to remove --cut--

BZ#1308765 sqlite-3.11.0 is available
User Icon xosevp commented & provided feedback 3 years ago
karma
User Icon rdieter commented & provided feedback 3 years ago
karma

the -libs subpkg split is probably missing an Obsoletes: sqlite < 3.11.0, upgrade path is broken

This update has been pushed to stable.

3 years ago
User Icon dani commented & provided feedback 3 years ago
karma

Upgrade does not work:

Skipping packages with broken dependencies: sqlite x86_64 3.11.0-1.fc23 updates 484 k

User Icon anonymous commented & provided feedback 3 years ago

Broken dependencies:

dnf update --best --allowerasing Error: cannot install both sqlite-3.11.0-1.fc23.x86_64 and sqlite-3.10.2-1.fc23.x86_64

karma: -1

BZ#1288606 Split library from binary to drop unnecessary dependencies.
User Icon anonymous commented & provided feedback 3 years ago

Broken dependencies.

karma: -1

BZ#1288606 Split library from binary to drop unnecessary dependencies.
User Icon remi commented & provided feedback 3 years ago

This update seems a terrible bad idea (especially the split)

Cannot downgrade because of DNF: https://bugzilla.redhat.com/1311037

Breaks Thunderbird: https://bugzilla.redhat.com/1311032

User Icon andyl33 commented & provided feedback 3 years ago

Solved: yum-deprecated remove sqlite-3.10.2-1.fc23.i686

=============================================
 Package               Arch      Version              
=============================================
Removing:
 sqlite                i686      3.10.2-1.fc23        
Removing for dependencies:
 gtk3                  i686      3.18.7-2.fc23        
 libcurl               i686      7.43.0-5.fc23        
 libreport             i686      2.6.4-1.fc23         
 libsoup               i686      2.52.2-1.fc23        
 nspluginwrapper       i686      1.4.4-22.fc23        
 nss                   i686      3.22.0-1.0.fc23      
 nss-softokn           i686      3.22.0-1.0.fc23      
 openldap              i686      2.4.40-14.fc23       
 pyzy                  i686      0.1.0-11.fc23        
 rest                  i686      0.7.93-2.fc23        
 rpm-libs              i686      4.13.0-0.rc1.11.fc23 
 rpm-plugin-selinux    i686      4.13.0-0.rc1.11.fc23 
 satyr                 i686      0.20-1.fc23          
 wine                  x86_64    1.9.3-1.fc23         
 wine-ldap             i686      1.9.3-1.fc23

Do your upgrade... Then reinstall wine:

yum-deprecated install wine

i686 versions of nss, nss-softokn, openldap, sqlite-libs, wine-ldap also reinstalled.

Then install the remaining packages that were uninstalled:

yum-deprecated install gtk3.i686 libcurl.i686 libreport.i686 libsoup.i686 nspluginwrapper.i686 pyzy.i686 rest.i686 rpm-libs.i686 rpm-plugin-selinux.i686 satyr.i686

These packages obviously depend on what if any you have installed.

I guess the update would not show any problems if wine and the i686 dependencies weren't installed.

User Icon danielkza commented & provided feedback 3 years ago
karma

This is currently breaking dnf upgrade in stable for me. As andyl33 mentioned I do have wine and a bunch of i686 deps installed.

User Icon anonymous commented & provided feedback 3 years ago

Breaks dnf update for me

$ sudo dnf update --best --allowerasing
Last metadata expiration check performed 0:00:54 ago on Fri Feb 26 08:06:28 2016.
Error: cannot install both sqlite-3.11.0-1.fc23.x86_64 and sqlite-3.10.2-1.fc23.x86_64

karma: -1


Please login to add feedback.

Metadata
Type
enhancement
Karma
-1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Dates
submitted
3 years ago
in testing
3 years ago
in stable
3 years ago
BZ#1288606 Split library from binary to drop unnecessary dependencies.
0
0
BZ#1308765 sqlite-3.11.0 is available
-1
0

Automated Test Results