Couple of fixes for pythondistdeps.py

How to install

sudo dnf upgrade --advisory=FEDORA-2016-9d1a2b5042

This update has been submitted for testing by ignatenkobrain.

3 years ago
User Icon ngompa commented & provided feedback 3 years ago
karma

Looks good to me.

BZ#1368673 pythondistdeps.py: 'NoneType' object has no attribute 'split'

This update has been pushed to testing.

3 years ago
User Icon lslebodn commented & provided feedback 3 years ago
karma

[root@host ~]# dnf update

Last metadata expiration check: 0:06:16 ago on Tue Aug 23 10:12:46 2016.

Dependencies resolved.

================================================================================

Package Arch Version Repository Size

================================================================================

Skipping packages with broken dependencies:

rpm x86_64 4.13.0-0.rc1.42.fc25 updates-testing 515 k

rpm-build x86_64 4.13.0-0.rc1.42.fc25 updates-testing 146 k

rpm-build-libs x86_64 4.13.0-0.rc1.42.fc25 updates-testing 120 k

rpm-libs x86_64 4.13.0-0.rc1.42.fc25 updates-testing 297 k

rpm-plugin-selinux x86_64 4.13.0-0.rc1.42.fc25 updates-testing 56 k

rpm-plugin-systemd-inhibit x86_64 4.13.0-0.rc1.42.fc25 updates-testing 56 k

Transaction Summary

================================================================================

Skip 6 Packages

Nothing to do.

Complete!

User Icon lslebodn commented & provided feedback 3 years ago

[root@host ~]# dnf update --best

Last metadata expiration check: 0:12:30 ago on Tue Aug 23 10:12:46 2016.

Error: package python2-rpm-4.13.0-0.rc1.41.fc26.x86_64 requires rpm(x86-64) =

4.13.0-0.rc1.41.fc26, but none of the providers can be installed.

package python3-rpm-4.13.0-0.rc1.41.fc26.x86_64 requires rpm(x86-64) =

4.13.0-0.rc1.41.fc26, but none of the providers can be installed.

package python2-rpm-4.13.0-0.rc1.41.fc26.x86_64 requires rpm(x86-64) =

4.13.0-0.rc1.41.fc26, but none of the providers can be installed.

package python3-rpm-4.13.0-0.rc1.41.fc26.x86_64 requires rpm(x86-64) =

4.13.0-0.rc1.41.fc26, but none of the providers can be installed

(try to add '--allowerasing' to command line to replace conflicting packages)

User Icon ignatenkobrain commented & provided feedback 3 years ago

@lslebodn .41.fc26 is not something what is included in this update. Please report bug.

User Icon mildew commented & provided feedback 3 years ago
karma

Works for me.

User Icon lslebodn commented & provided feedback 3 years ago

@ignatenkobrain It's true that I have rpm*.41.fc26 on my system. because I had a rawhide and later switched to f25

But It does not change the fact that packages for this update has newer NEVR and update is broken.

BTW upgrade with enabled rawhide does not cause a problem dnf update --enablerepo=rawhide rpm

I assume it is cause by renaming of rpm-python* only in rawhide. Is there a reason why it was not renamed in f25?

User Icon ignatenkobrain commented & provided feedback 3 years ago

@lslebodn as it is requires some testing before I would like to put it into stable branches.

ignatenkobrain edited this update.

New build(s):

  • rpm-4.13.0-0.rc1.44.fc25

Removed build(s):

  • rpm-4.13.0-0.rc1.42.fc25
3 years ago

This update has been submitted for testing by ignatenkobrain.

3 years ago

This update has been pushed to testing.

3 years ago

This update has been submitted for stable by bodhi.

3 years ago
User Icon lslebodn commented & provided feedback 3 years ago
karma

Issue with 4.13.0-0.rc1.42.fc25 is fixed

+1

User Icon pbrobinson commented & provided feedback 3 years ago
karma

Some sort of issue with this that's causing dnf to skip this. I suspect a random soname bump but as dnf doesn't report why I can't give more details.

Dependencies resolved.

Package Arch Version Repository Size

Skipping packages with broken dependencies: rpm x86_64 4.13.0-0.rc1.44.fc25 updates-testing 516 k rpm-build x86_64 4.13.0-0.rc1.44.fc25 updates-testing 146 k rpm-build-libs x86_64 4.13.0-0.rc1.44.fc25 updates-testing 120 k rpm-libs x86_64 4.13.0-0.rc1.44.fc25 updates-testing 297 k rpm-plugin-selinux x86_64 4.13.0-0.rc1.44.fc25 updates-testing 56 k rpm-plugin-systemd-inhibit x86_64 4.13.0-0.rc1.44.fc25 updates-testing 56 k rpm-sign x86_64 4.13.0-0.rc1.44.fc25 updates-testing 59 k

Transaction Summary

Skip 7 Packages

Nothing to do. Complete!

BZ#1368673 pythondistdeps.py: 'NoneType' object has no attribute 'split'

ignatenkobrain edited this update.

New build(s):

  • rpm-4.13.0-0.rc1.45.fc25

Removed build(s):

  • rpm-4.13.0-0.rc1.44.fc25
3 years ago

This update has been submitted for testing by ignatenkobrain.

3 years ago

ignatenkobrain edited this update.

New build(s):

  • rpm-4.13.0-0.rc1.46.fc25

Removed build(s):

  • rpm-4.13.0-0.rc1.45.fc25
3 years ago

This update has been pushed to testing.

3 years ago

This update has been submitted for stable by bodhi.

3 years ago
User Icon lslebodn commented & provided feedback 3 years ago
karma

+1

This update has been pushed to stable.

3 years ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
1
Stable by Time
disabled
Dates
submitted
3 years ago
in testing
3 years ago
in stable
3 years ago
modified
3 years ago
BZ#1368673 pythondistdeps.py: 'NoneType' object has no attribute 'split'
0
0

Automated Test Results