stable

SDL2-2.0.4-6.fc23

FEDORA-2016-a9097aa363 created by ignatenkobrain 8 years ago for Fedora 23

Fix running on wayland

How to install

Updates may require up to 24 hours to propagate to mirrors. If the following command doesn't work, please retry later:

sudo dnf upgrade --refresh --advisory=FEDORA-2016-a9097aa363

This update has been submitted for testing by ignatenkobrain.

8 years ago

This update has been pushed to testing.

8 years ago
User Icon karthikrajprkkr17 commented & provided feedback 8 years ago
karma

lgtm:)

This update has been submitted for stable by bodhi.

8 years ago
User Icon jwmullally commented & provided feedback 8 years ago
karma

+1

Fix works, SDL2 test applications run OK. Tested in FC23 i386.

Tests

$ cat test_sdl.c
#include <stdio.h>
#include <SDL.h>
int main( int argc, char *argv[] ) {
    if( SDL_Init( SDL_INIT_VIDEO ) < 0 ) {
        printf( "SDL_Init() error: %s\n", SDL_GetError() );
        return 1;
    }
    printf( "SDL_Init() succeeded.\n" );
    printf( "SDL_GetCurrentVideoDriver(): %s\n", SDL_GetCurrentVideoDriver() );
    return 0;
}
$ gcc -o test_sdl test_sdl.c -g -lSDL2 -I/usr/include/SDL2

$ ./test_sdl 
SDL_Init() succeeded.
SDL_GetCurrentVideoDriver(): x11
<ok>

$ SDL_VIDEODRIVER=wayland ./test_sdl 
SDL_Init() succeeded.
SDL_GetCurrentVideoDriver(): wayland
<ok>

$ ~/rpmbuild/BUILD/SDL2-2.0.4/test/testdisplayinfo 
INFO: Using video target 'x11'.
<ok>

$ SDL_VIDEODRIVER=wayland ~/rpmbuild/BUILD/SDL2-2.0.4/test/testdisplayinfo 
INFO: Using video target 'wayland'.
<ok>

$ ~/rpmbuild/BUILD/SDL2-2.0.4/test/testgl2
<ok>

$ SDL_VIDEODRIVER=wayland ~/rpmbuild/BUILD/SDL2-2.0.4/test/testgl2
<ok>
BZ#1354155 SDL_Init fails when SDL_VIDEODRIVER=wayland

This update has been pushed to stable.

8 years ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
high
Karma
2
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
2
Stable by Time
disabled
Dates
submitted
8 years ago
in testing
8 years ago
in stable
8 years ago
BZ#1354155 SDL_Init fails when SDL_VIDEODRIVER=wayland
0
1

Automated Test Results