FEDORA-2016-aa301aab71

enhancement update in Fedora 24 for ecj, eclipse, & 16 more

Status: stable 3 years ago

Update to Eclipse Neon. See the upstream new & noteworthy document for the full list of changes: https://www.eclipse.org/eclipse/news/4.6/


Additionally, Eclipse now uses Webkit 2 by default in Fedora for increased stability and security. Webkit 1 can still be used by setting SWT_WEBKIT2=0 in the environment.


Enables "discovery" modules of Eclipse Communication Framework.


Fix the Eclipse PDE Target Platform droplet bundle detection.

Before this change, any bundle from a droplet location (most bundles now) would not show up as part of the default target platform (generated from existing eclipse rpm bundles). This should be fixed now, and bundles within droplets should show up as part of the PDE target platform.

If already using a PDE target platform, it may be necessary to re-generate it from the 'default' option to see the changes.

Comments 32

This update has been submitted for testing by mbooth.

mbooth edited this update.

mbooth edited this update.

New build(s):

  • eclipse-pydev-4.5.5-3.fc24

mbooth edited this update.

New build(s):

  • eclipse-cdt-9.0.0-0.3.git0b93e81.fc24

mbooth edited this update.

New build(s):

  • eclipse-linuxtools-5.0.0-0.1.gitc2364c0.fc24

mbooth edited this update.

New build(s):

  • eclipse-ptp-9.0.2-2.fc24
  • eclipse-swtbot-2.4.0-2.fc24

mbooth edited this update.

New build(s):

  • eclipse-photran-9.1.0-3.fc24

mbooth edited this update.

New build(s):

  • eclipse-ecf-3.13.1-1.fc24

This update has obsoleted eclipse-4.5.2-10.fc24, and has inherited its bugs and notes.

sopotc edited this update.

New build(s):

  • eclipse-pydev-4.6.0-1.fc24

Removed build(s):

  • eclipse-pydev-4.5.5-3.fc24

mbooth edited this update.

New build(s):

  • eclipse-eclemma-2.3.3-2.fc24

mbooth edited this update.

This update has been pushed to testing.

Works great! LGTM! =)

karma: +1

I installed F24 alpha two days agora. At that time I installed the "Fedora Eclipse" group. Today, I got this update from updates-testing. After the update, I cannot get Eclipse to start a fresh workspace. It generates a .log file in the .metadata directory of the target workspace with many errors. Please advise.

@pedrolamarao: Thanks for testing. It's hard to say without seeing the log. Can you file a bug on component "eclipse" and attach it? That way I can inspect it.

sopotc edited this update.

New build(s):

  • eclipse-fedorapackager-0.6.0-0.1.gitb0ca8af.fc24

This update has been submitted for testing by sopotc.

Fails to start, even with a fresh workspace, -clean and ~/.eclipse deleted.

See bug #1333480 for details (as above)

karma: -1

This update has been pushed to testing.

This update has reached 3 days in testing and can be pushed to stable now if the maintainer wishes

works for me

karma: +1

mbooth edited this update.

New build(s):

  • eclipse-4.6.0-0.6.git201605092000.fc24
  • eclipse-emf-2.12.0-0.1.git2021583.fc24

Removed build(s):

  • eclipse-4.6.0-0.5.git201604261105.fc24

This update has been submitted for testing by mbooth.

mbooth edited this update.

New build(s):

  • eclipse-e4-importer-0.2.0-0.2.gitb33919c.fc24

Removed build(s):

  • eclipse-e4-importer-0.2.0-0.1.git8af671a.fc24

This update has been pushed to testing.

Still running into #1333480, other than that eclipse is working fine.

karma: -1 #1303912: +1

Bug 1333480 still happens for me.

Clearly it does not affect everyone. I will push the update since pre-release Fedora has updates-testing enabled by default anyway. Let's continue working the problem in the bug.

This update has been submitted for stable by mbooth.

This update has been pushed to stable.

Add Comment & Feedback

Please login to add feedback.

Content Type
RPM
Status
stable
Test Gating
Submitted by
Update Type
enhancement
Update Severity
unspecified
Karma
-1
stable threshold: 3
unstable threshold: -3
Autopush (karma)
Enabled
Autopush (time)
Disabled
Dates
submitted 3 years ago
in testing 3 years ago
in stable 3 years ago
modified 3 years ago

Related Bugs 3

00 #1202238 eclipse: Dropin cache not updated completely
00 #1210898 Eclipse tries to use non-existent Mozilla (xulrunner) browser
0+1 #1303912 drop dependency on WebKit 1 Gtk bindings

Automated Test Results