stable

php-swiftmailer-5.4.5-1.fc24

FEDORA-2016-b65e546846 created by remi 7 years ago for Fedora 24

Version 5.4.5 (2016-12-29)

  • SECURITY FIX: fixed CVE-2016-10074 by disallowing potentially unsafe shell characters

Prior to 5.4.5, the mail transport (Swift_Transport_MailTransport) was vulnerable to passing arbitrary shell arguments if the "From", "ReturnPath" or "Sender" header came from a non-trusted source, potentially allowing Remote Code Execution

  • deprecated the mail transport

How to install

Updates may require up to 24 hours to propagate to mirrors. If the following command doesn't work, please retry later:

sudo dnf upgrade --refresh --advisory=FEDORA-2016-b65e546846

This update has been submitted for testing by remi.

7 years ago

This update has been pushed to testing.

7 years ago

remi edited this update.

7 years ago

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

7 years ago

This update has been submitted for stable by remi.

7 years ago

This update has been pushed to stable.

7 years ago

Please login to add feedback.

Metadata
Type
security
Karma
0
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
7 years ago
in testing
7 years ago
in stable
7 years ago
modified
7 years ago
BZ#1409517 CVE-2016-10074 php-swiftmailer: Parameter injection via mail() function
0
0
BZ#1409518 CVE-2016-10074 php-swiftmailer: Parameter injection via mail() function [fedora-all]
0
0

Automated Test Results