How to install

sudo dnf upgrade --advisory=FEDORA-2016-bdc07e5732

This update has been submitted for testing by rdieter.

3 years ago

This update has been pushed to testing.

3 years ago
User Icon khalak commented & provided feedback 3 years ago
karma
dnf install kde-runtime-kuiserver-15.12.2-1.fc22.x86_64.rpm ../noarch/kde-runtime-docs-15.12.2-1.fc22.noarch.rpm
Last metadata expiration check performed 0:17:54 ago on Wed Feb 17 17:37:47 2016.
Error: installed package plasma-workspace-5.5.4-2.fc22.x86_64 obsoletes kde-runtime-kuiserver < 1:15.08.2 provided by kde-runtime-kuiserver-15.12.2-1.fc22.x86_64.
installed package plasma-desktop-doc-5.5.4-1.fc22.noarch obsoletes kde-runtime-docs < 1:14.12.3-2 provided by kde-runtime-docs-15.12.2-1.fc22.noarch
(try to add '--allowerasing' to command line to replace conflicting packages)

Add Epoch to the spec file

No problems and/or regressions (standard package-set, kde-runtime-kuiserver + kde-runtime-docs not installed).

karma: +1

khalak, neither -kuiserver or -doc are intended to be installable when using plasma5. that's what dnf is trying to tell you. We provide those for users who wanted to continue using kde4 only.

User Icon khalak commented & provided feedback 3 years ago
karma

@rdieter: indeed, I overlooked in Notes 'KDE4 Core/Runtime components…'. Reverting karma from -1 to +1 = neutral. That -kuiserver and -doc come from the same build kde-runtime-15.12.2-1.fc22 in koji, from which all the rest of the packages, i.e. -runtime, -runtime-devel, -runtime-drkonqi, -runtime-drkonqi, -runtime-libs and noarch's -runtime-flags installed not throwing an error, renders my confusion natural. I still, however, could not plausibly get how come kde-runtime-kuiserver < 1:15.08.2 is provided by kde-runtime-kuiserver-15.12.2-1(?!), and the same goes with kde-runtime-docs…

That's just how Obsoletes: tag works. plasma-workspace has Obsoletes: kde-runtime-kuiserver < 1:15.08.2 , and plasma-workspace-doc has Obsoletes: kde-runtime-docs < 1:14.12.3-2

rdieter edited this update.

3 years ago

This update has been submitted for stable by bodhi.

3 years ago
karma

This update has been pushed to stable.

3 years ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
low
Karma
2
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-4
Stable by Karma
2
Dates
submitted
3 years ago
in testing
3 years ago
in stable
3 years ago
modified
3 years ago

Automated Test Results