stable

nss-3.24.0-1.2.fc23

FEDORA-2016-db48cd10e9 created by emaldonado 8 years ago for Fedora 23

Fix a bug introduced with the update to nss-3.24, that SSLSv2 support removed, that caused of IPA failures because nss init failed.

How to install

Updates may require up to 24 hours to propagate to mirrors. If the following command doesn't work, please retry later:

sudo dnf upgrade --refresh --advisory=FEDORA-2016-db48cd10e9

This update has been submitted for testing by emaldonado.

8 years ago
User Icon amessina commented & provided feedback 8 years ago
karma

Resolves #1342158

BZ#1342158 nss-3.24 does no longer support ssl V2, installation of IPA fails because nss init fails

This update has been pushed to testing.

8 years ago
User Icon mhjacks commented & provided feedback 8 years ago
karma

My freeipa servers failed to restart after the first 3.24 update. This update resolved that problem.

BZ#1342158 nss-3.24 does no longer support ssl V2, installation of IPA fails because nss init fails

This update has been submitted for stable by bodhi.

8 years ago
User Icon oron commented & provided feedback 8 years ago
karma

Fixed my freeipa server problem.

Minor IPA / nss related issues (not directly related to this fix):

  • httpd output a warning:

    • "module nss_module is already loaded, skipping"
    • This is because /etc/httpd/conf.modules.d/10-nss.conf already loads the module
    • But the "ipa-client-install" also configure it in /etc/httpd/conf.d/nss.conf
  • Also, in /etc/httpd/conf.d/nss.conf:

    • There's a non-default "NSSPassPhraseHelper"
    • It is set to /usr/libexec/nss_pcache vs. /usr/sbin/nss_pcache
    • But the /usr/sbin/nss_pcache is currently symlink to /usr/libexec/nss_pacache (both owned by mod_nss)
  • Seems freeipa can minimize diffs from "nss" + "mod_nss" rpms.
BZ#1342158 nss-3.24 does no longer support ssl V2, installation of IPA fails because nss init fails
User Icon lupinix commented & provided feedback 8 years ago
karma

Works fine again

BZ#1342158 nss-3.24 does no longer support ssl V2, installation of IPA fails because nss init fails

This update has been pushed to stable.

8 years ago

Please login to add feedback.

Metadata
Type
enhancement
Karma
4
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
8 years ago
in testing
8 years ago
in stable
8 years ago
BZ#1342158 nss-3.24 does no longer support ssl V2, installation of IPA fails because nss init fails
0
4

Automated Test Results