Fixes problems with failing to build and load Eclipse PHP Development Tools and fixes problems with Eclipse failing to start after creating a new workspace.


Updates to Neon to sync with rest of the Eclipse stack.

How to install

sudo dnf upgrade --advisory=FEDORA-2016-e382dece0e

This update has been submitted for testing by mbooth.

3 years ago

This update has obsoleted eclipse-gef-3.11.0-0.1gitd3e8eb2.fc24, and has inherited its bugs and notes.

3 years ago
User Icon prakashmishra1598 commented & provided feedback 3 years ago
karma

LGTM

This update has been pushed to testing.

3 years ago
User Icon akurtakov commented & provided feedback 3 years ago
karma

works for me

mbooth edited this update.

New build(s):

  • eclipse-mpc-1.5.0-2.fc24
  • eclipse-nls-4.5.0.v20151128060001-2.fc24
3 years ago

This update has been submitted for testing by mbooth.

3 years ago

mbooth edited this update.

3 years ago

This update has been pushed to testing.

3 years ago
User Icon genodeftest commented & provided feedback 3 years ago
karma

When just having eclipse-nls, but no eclipse-nls-[languagecode] installed, this update wants to install ALL language packs. When I want to install eclipse-nls-de, the same thing happens: dnf proposes to install all ~40 language packs.

User Icon genodeftest commented & provided feedback 3 years ago
karma

Workaround for dnf trying to install ALL language packs:

  1. remove eclipse-nls
  2. dnf upgrade
  3. install your eclipse-nls-[languagecode] package again

Of course this should not be done by users. Please fix packaging before pushing to stable.

User Icon mbooth commented & provided feedback 3 years ago

Hmm, for me dnf just picks the first match (lexicographically, I guess) which happens to be "eclipse-nls-ar" and proposes to install only that. This is my dnf output: https://paste.fedoraproject.org/390591/04320146/

Can you please post steps to reproduce this, @genodeftest?

User Icon genodeftest commented & provided feedback 3 years ago

Steps to reproduce:

  1. install a clean Fedora 24 live (build 1.2) x86_64 installation
  2. run dnf langinstall de as root
  3. run dnf install eclipse-nls as root
  4. enable updates-testing repositories. You'll probably need an editor for that.
  5. run dnf upgrade or just dnf upgrade eclipse-\*

I can also create a new bug report for that if you wish.

If this issue doesn't affect you, you might be using default (English) locale or might not have language packs enabled.

User Icon genodeftest commented & provided feedback 3 years ago

Also happens without the German langpack installed, i.e. running dnf langremove de before 5. Probably work even when leaving out step 2. completely.

This update has been obsoleted.

3 years ago
User Icon nullpointer00 commented & provided feedback 3 years ago
karma

I did "dnf --enablerepo=update-testing upgrade 'eclipse' 'lucene' and works. But I soon as I did "dnf --enablerepo=update-testing install eclipse-nls-es", it broke again.

This update has been submitted for testing by mbooth.

3 years ago

mbooth edited this update.

New build(s):

  • eclipse-pdt-4.0.0-2.fc24
  • eclipse-dltk-5.5.0-3.fc24

Removed build(s):

  • eclipse-pdt-4.0.0-1.fc24
  • eclipse-dltk-5.5.0-2.fc24
3 years ago

mbooth edited this update.

New build(s):

  • eclipse-nls-4.5.0.v20151128060001-3.fc24

Removed build(s):

  • eclipse-nls-4.5.0.v20151128060001-2.fc24
3 years ago
User Icon mbooth commented & provided feedback 3 years ago

@genodeftest, please try again with this latest build

User Icon genodeftest commented & provided feedback 3 years ago

@mbooth: I'll do as soon as they land on update-testing for me.

I just noticed that I'm still on eclipse-nls-4.5.0.v20150804081228-3.fc24, so my computer didn't even get the first update to eclipse-nls-4.5.0.v20151128060001-2.fc24. Does that matter? I don't really understand…

User Icon mbooth commented & provided feedback 3 years ago

No, it shouldn't matter -- just make sure to remove any language-specific package before upgrading, this way you can test that you don't get all of them installed all trying to obsolete the same package :-) (i.e. same scenario as you highlighted above)

This update has been pushed to testing.

3 years ago
karma
BZ#1350300 Failure to start Eclipse IDE after update to Fedora 24
BZ#1333480 Eclipse won't start a fresh workspace
BZ#1348942 eclipse neon fails to load perspective

This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes

3 years ago

This update has been submitted for stable by mbooth.

3 years ago

This update has been pushed to stable.

3 years ago

Please login to add feedback.

Metadata
Type
bugfix
Severity
medium
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Dates
submitted
3 years ago
in testing
3 years ago
in stable
3 years ago
modified
3 years ago
BZ#1333480 Eclipse won't start a fresh workspace
0
1
BZ#1348274 eclipse-pdt: FTBFS in rawhide
0
0
BZ#1348942 eclipse neon fails to load perspective
0
1
BZ#1350300 Failure to start Eclipse IDE after update to Fedora 24
0
1

Automated Test Results