• Fixes #1405814 ipa plugins: ERROR an internal error occured
  • Fixes #1430247 FreeIPA server deployment runs ipa-custodia on Python 3, should use Python 2
  • Fixes #1446744 python2-ipaclient subpackage does not own %{python_sitelib}/ipaclient/plugins
  • Fixes #1440525 surplus 'the' in output of ipa-adtrust-install
  • Fixes #1411810 ipa-replica-install fails with 406 Client Error

How to install

sudo dnf upgrade --advisory=FEDORA-2017-0d0ec3e0af

This update has been submitted for testing by tkrizek.

2 years ago

This update has been pushed to testing.

2 years ago

This update has reached 3 days in testing and can be pushed to stable now if the maintainer wishes

2 years ago
User Icon pbrobinson commented & provided feedback 2 years ago
karma

Error: Problem 1: problem with installed package freeipa-client-4.4.4-2.fc26.armv7hl - package freeipa-client-4.4.4-1.fc26.armv7hl conflicts with ipa-client provided by freeipa-client-4.4.4-2.fc26.armv7hl - package freeipa-server-4.4.4-1.fc26.armv7hl requires freeipa-client = 4.4.4-1.fc26, but none of the providers can be installed - conflicting requests - package freeipa-server-4.4.4-2.fc26.armv7hl requires freeipa-server-common = 4.4.4-2.fc26, but none of the providers can be installed - nothing provides custodia >= 0.3.1 needed by freeipa-server-common-4.4.4-2.fc26.noarch Problem 2: problem with installed package freeipa-common-4.4.4-2.fc26.noarch - package freeipa-common-4.4.4-1.fc26.noarch conflicts with ipa-common provided by freeipa-common-4.4.4-2.fc26.noarch - package freeipa-server-4.4.4-1.fc26.armv7hl requires freeipa-common = 4.4.4-1.fc26, but none of the providers can be installed - package freeipa-server-dns-4.4.4-1.fc26.noarch requires freeipa-server = 4.4.4-1.fc26, but none of the providers can be installed - conflicting requests - package freeipa-server-dns-4.4.4-2.fc26.noarch requires freeipa-server = 4.4.4-2.fc26, but none of the providers can be installed - package freeipa-server-4.4.4-2.fc26.armv7hl requires freeipa-server-common = 4.4.4-2.fc26, but none of the providers can be installed - nothing provides custodia >= 0.3.1 needed by freeipa-server-common-4.4.4-2.fc26.noarch

Bodhi is disabling automatic push to stable due to negative karma. The maintainer may push manually if they determine that the issue is not severe.

2 years ago
User Icon tkrizek commented & provided feedback 2 years ago

The above is caused by missing custodia >= 0.3.1, there's already a bodhi update for it:

https://bodhi.fedoraproject.org/updates/custodia-0.3.1-2.fc26

User Icon abbra commented & provided feedback 2 years ago

It would be good to have a combined update with custodia. This way we can guarantee there is no issue in upgrading both packages.

This update has been unpushed.

simo edited this update.

New build(s):

  • custodia-0.3.1-2.fc26

Karma has been reset.

2 years ago

This update has been submitted for testing by simo.

2 years ago
User Icon simo commented & provided feedback 2 years ago

Added custodia to the update and re-pushed

This update has been pushed to testing.

2 years ago

This update has reached 3 days in testing and can be pushed to stable now if the maintainer wishes

2 years ago

This update has been submitted for stable by simo.

2 years ago
User Icon abbra commented & provided feedback 2 years ago
karma

Worked for me with custodia 0.5 -> 0.3.1 downgrade just fine.

This update has been pushed to stable.

2 years ago

Please login to add feedback.

Metadata
Type
bugfix
Karma
1
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Dates
submitted
2 years ago
in testing
2 years ago
in stable
2 years ago
modified
2 years ago
BZ#1405814 ipa plugins: ERROR an internal error occured.
0
0
BZ#1411810 ipa-replica-install fails with 406 Client Error: Key name ca/caSigningCert%20cert-pki-ca does not match subject ca/caSigningCert cert-pki-ca
0
0
BZ#1426737 custodia: Provide a Python 3 subpackage
0
0
BZ#1430247 FreeIPA server deployment runs ipa-custodia on Python 3, should use Python 2
0
0
BZ#1440525 surplus 'the' in output of `ipa-adtrust-install`
0
0
BZ#1446744 python2-ipaclient subpackage does not own %{python_sitelib}/ipaclient/plugins
0
0

Automated Test Results