FEDORA-2017-24169bbb2d

enhancement update in Fedora 27 for nss, nss-pem, & 2 more

Status: stable 2 years ago

Updates the nss family of packages to upstream NSS 3.34.

For details about new functionality and a list of bugs fixed in this release please see the upstream release notes

https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.34_release_notes

How to install

sudo dnf upgrade --advisory=FEDORA-2017-24169bbb2d

Comments 20

This update has been submitted for testing by ueno.

This update has been pushed to testing.

Problem 1: cannot install the best update candidate for package nss-3.33.0-1.0.fc27.i686

  • nothing provides nss-pem(x86-32) needed by nss-3.34.0-1.0.fc27.i686

Problem 2: package openldap-2.4.45-3.fc27.i686 requires libnss3.so, but none of the providers can be installed

  • nss-3.33.0-1.0.fc27.i686 has inferior architecture
  • cannot install both nss-3.34.0-1.0.fc27.x86_64 and nss-3.33.0-1.0.fc27.x86_64
  • cannot install both nss-3.33.0-1.0.fc27.x86_64 and nss-3.34.0-1.0.fc27.x86_64
  • cannot install the best update candidate for package openldap-2.4.45-3.fc27.i686
  • cannot install the best update candidate for package nss-3.33.0-1.0.fc27.x86_64
  • nothing provides nss-pem(x86-32) needed by nss-3.34.0-1.0.fc27.i686

Happenes under the preposition having wine installed on the system.

karma: -1

ueno edited this update.

New build(s):

  • nss-pem-1.0.3-6.fc27

Karma has been reset.

This update has been submitted for testing by ueno.

Added nss-pem build to this update to resolve the issue, per Kamil's suggestion on bug 1500655

Works

karma: +1

Problem 1:

    cannot install the best update candidate for package nss-3.33.0-1.0.fc27.i686
  - nothing provides nss-pem(x86-32) needed by nss-3.34.0-1.0.fc27.i686

Problem 2:

    package redhat-lsb-submod-security-4.1-36.fc27.i686 requires nss(x86-32),
but none of the providers can be installed
  - nss-3.33.0-1.0.fc27.i686 has inferior architecture
  - cannot install both nss-3.34.0-1.0.fc27.x86_64 and nss-3.33.0-1.0.fc27.x86_64
  - cannot install both nss-3.33.0-1.0.fc27.x86_64 and nss-3.34.0-1.0.fc27.x86_64
  - cannot install the best update candidate for package redhat-lsb-submod-security-4.1-36.fc27.i686
  - cannot install the best update candidate for package nss-3.33.0-1.0.fc27.x86_64
  - nothing provides nss-pem(x86-32) needed by nss-3.34.0-1.0.fc27.i686

This update has been pushed to testing.

works for me

karma: +1

No Regressions noted

karma: +1

This update has reached the stable karma threshold and can be pushed to stable now if the maintainer wishes.

Seems good

karma: +1

No regressions here.

karma: +1

Can this please be pushed to stable if the responses are ok? It would fix Steam (or any user that relies on openLDAP) on Fedora27 due to the lack of nss-pem.i686

works for me

karma: +1

This update has been submitted for batched by ueno.

This update has been submitted for stable by ueno.

This update has been pushed to stable.

Add Comment & Feedback

Please login to add feedback.

Content Type
RPM
Status
stable
Test Gating
Submitted by
Update Type
enhancement
Update Severity
unspecified
Karma
+7
stable threshold: 3
unstable threshold: -3
Autopush (karma)
Disabled
Autopush (time)
Disabled
Dates
submitted 2 years ago
in testing 2 years ago
in stable 2 years ago
modified 2 years ago

Related Bugs 3

00 #1482798 Illegal instruction in SHA1_Update() when used by chronyd
00 #1500655 nss-pem error while updating to fedora 27
00 #1512906 nss-3.34 is available

Automated Test Results