OpenVPN 2.4 removes the deprecated --tls-remote option. Add a workaround in the nm-openvpn plugin not to break existing connection (#1421241)

How to install

sudo dnf upgrade --advisory=FEDORA-2017-3870a93455

This update has been submitted for testing by thaller.

3 years ago

This update has been pushed to testing.

3 years ago
User Icon cserpentis commented & provided feedback 3 years ago
karma

works for me

User Icon kparal commented & provided feedback 3 years ago
karma

works even with my VPN config that broke with latest proposed update

BZ#1421241 Options error: Unrecognized option or missing or extra parameter(s) in [CMD-LINE]:1: tls-remote (2.4.0)
User Icon besser82 commented & provided feedback 3 years ago
karma

Works great! LGTM! =)

This update has been submitted for stable by bodhi.

3 years ago
User Icon dimitrisk commented & provided feedback 3 years ago
karma

WFM - does that mean we're getting openvpn 2.4 in F25?

This update has been pushed to stable.

3 years ago
User Icon thaller commented & provided feedback 3 years ago

@dimitrisk, I don't have any say in that, but I would hope to not get it, because it still breaks all users of openvpn and use the deprecated --tls-remote option in their ovpn files (not NetworkManager users). I don't think such a change is f25 material.


Please login to add feedback.

Metadata
Type
enhancement
Karma
4
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Stable by Time
disabled
Dates
submitted
3 years ago
in testing
3 years ago
in stable
3 years ago
BZ#1421241 Options error: Unrecognized option or missing or extra parameter(s) in [CMD-LINE]:1: tls-remote (2.4.0)
0
1

Automated Test Results