FEDORA-2017-48014f1cad created by jchaloup 2 years ago for Fedora 26
stable

Update to v1.6.7


Update to 1.6.1


Bump to v1.5.4

How to install

sudo dnf upgrade --advisory=FEDORA-2017-48014f1cad

This update has been submitted for testing by jchaloup.

2 years ago

This update has obsoleted kubernetes-1.6.1-1.fc26, and has inherited its bugs and notes.

2 years ago
User Icon jasonbrooks commented & provided feedback 2 years ago
karma

I tested this with a cluster, it works, but it doesn't include a fix for #1468752.

BZ#1468823 Build kubernetes 1.6.7
BZ#1441218 Regression: kube-apiserver.service fails to start: first path segment in URL cannot contain colon
User Icon jchaloup commented & provided feedback 2 years ago

1468752 is fixes via kubernetes/contrib/init/systemd/environ/kubelet file. It works for a non-ansible deployment.

This update has been pushed to testing.

2 years ago
User Icon sjenning provided feedback 2 years ago
karma
BZ#1468823 Build kubernetes 1.6.7
BZ#1468752 kubelet requires --cgroup-driver=systemd in its conifguration
BZ#1441218 Regression: kube-apiserver.service fails to start: first path segment in URL cannot contain colon
User Icon jberkus commented & provided feedback 2 years ago
karma

Tested using the Kubernetes Getting Started docs on projectatomic.io

BZ#1422889 Update to upstream 1.5.3
BZ#1468823 Build kubernetes 1.6.7
BZ#1468752 kubelet requires --cgroup-driver=systemd in its conifguration
BZ#1423829 kubernetes: FTBFS in rawhide
BZ#1441218 Regression: kube-apiserver.service fails to start: first path segment in URL cannot contain colon

This update has been submitted for stable by bodhi.

2 years ago

This update has been pushed to stable.

2 years ago
User Icon strigazi commented & provided feedback 2 years ago
karma

Tested with docker 1.12. serviceaccount with tls is working. Manually added kubernetes-dashboard and coredns, they work fine.

https://github.com/strigazi/deploy-kube/blob/master/fedora-rpms.sh

BZ#1422889 Update to upstream 1.5.3
BZ#1468823 Build kubernetes 1.6.7
BZ#1468752 kubelet requires --cgroup-driver=systemd in its conifguration
BZ#1423829 kubernetes: FTBFS in rawhide
BZ#1441218 Regression: kube-apiserver.service fails to start: first path segment in URL cannot contain colon

Please login to add feedback.

Metadata
Type
enhancement
Karma
4
Signed
Content Type
RPM
Test Gating
Settings
Unstable by Karma
-3
Stable by Karma
3
Dates
submitted
2 years ago
in testing
2 years ago
in stable
2 years ago
BZ#1422889 Update to upstream 1.5.3
0
2
BZ#1423829 kubernetes: FTBFS in rawhide
0
2
BZ#1441218 Regression: kube-apiserver.service fails to start: first path segment in URL cannot contain colon
0
4
BZ#1468752 kubelet requires --cgroup-driver=systemd in its conifguration
0
3
BZ#1468823 Build kubernetes 1.6.7
0
4

Automated Test Results